summaryrefslogtreecommitdiffstats
path: root/src/kmk/config
diff options
context:
space:
mode:
Diffstat (limited to 'src/kmk/config')
-rw-r--r--src/kmk/config/.gitignore12
-rw-r--r--src/kmk/config/ChangeLog.149
-rw-r--r--src/kmk/config/Makefile.am18
-rw-r--r--src/kmk/config/dospaths.m433
4 files changed, 112 insertions, 0 deletions
diff --git a/src/kmk/config/.gitignore b/src/kmk/config/.gitignore
new file mode 100644
index 0000000..d11a488
--- /dev/null
+++ b/src/kmk/config/.gitignore
@@ -0,0 +1,12 @@
+ar-lib
+compile
+config.guess
+config.rpath
+config.sub
+depcomp
+install-sh
+mdate-sh
+missing
+texinfo.tex
+*.m4
+!dospaths.m4
diff --git a/src/kmk/config/ChangeLog.1 b/src/kmk/config/ChangeLog.1
new file mode 100644
index 0000000..8549501
--- /dev/null
+++ b/src/kmk/config/ChangeLog.1
@@ -0,0 +1,49 @@
+2012-01-15 Paul Smith <psmith@gnu.org>
+
+ * dospaths.m4: Use AC_LANG_PROGRAM to encapsulate the test code.
+ Fixes Savannah bug #35256. Patch from Sebastian Pipping.
+
+2006-03-09 Paul Smith <psmith@gnu.org>
+
+ * dospaths.m4: Add MSYS to the list of targets allowing DOS-style
+ pathnames. Reported by David Ergo <david.ergo@alterface.com>.
+
+2005-07-01 Paul D. Smith <psmith@gnu.org>
+
+ * Makefile.am (EXTRA_DIST): Added more M4 files to EXTRA_DIST, so
+ users can re-run aclocal.
+
+2003-04-30 Paul D. Smith <psmith@gnu.org>
+
+ * dospaths.m4: New macro to test for DOS-style pathnames, based on
+ coreutils 5.0 "dos.m4" by Jim Meyering.
+
+2002-04-21 gettextize <bug-gnu-gettext@gnu.org>
+
+ * codeset.m4: New file, from gettext-0.11.1.
+ * gettext.m4: New file, from gettext-0.11.1.
+ * glibc21.m4: New file, from gettext-0.11.1.
+ * iconv.m4: New file, from gettext-0.11.1.
+ * isc-posix.m4: New file, from gettext-0.11.1.
+ * lcmessage.m4: New file, from gettext-0.11.1.
+ * lib-ld.m4: New file, from gettext-0.11.1.
+ * lib-link.m4: New file, from gettext-0.11.1.
+ * lib-prefix.m4: New file, from gettext-0.11.1.
+ * progtest.m4: New file, from gettext-0.11.1.
+ * Makefile.am: New file.
+
+
+Copyright (C) 2002-2016 Free Software Foundation, Inc.
+This file is part of GNU Make.
+
+GNU Make is free software; you can redistribute it and/or modify it under the
+terms of the GNU General Public License as published by the Free Software
+Foundation; either version 3 of the License, or (at your option) any later
+version.
+
+GNU Make is distributed in the hope that it will be useful, but WITHOUT ANY
+WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
+A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License along with
+this program. If not, see <http://www.gnu.org/licenses/>.
diff --git a/src/kmk/config/Makefile.am b/src/kmk/config/Makefile.am
new file mode 100644
index 0000000..7bce036
--- /dev/null
+++ b/src/kmk/config/Makefile.am
@@ -0,0 +1,18 @@
+# -*-Makefile-*-, or close enough
+# Copyright (C) 2002-2016 Free Software Foundation, Inc.
+# This file is part of GNU Make.
+#
+# GNU Make is free software; you can redistribute it and/or modify it under
+# the terms of the GNU General Public License as published by the Free
+# Software Foundation; either version 3 of the License, or (at your option)
+# any later version.
+#
+# GNU Make is distributed in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
+# details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program. If not, see <http://www.gnu.org/licenses/>.
+
+# Autoconf / automake know how to handle this directory.
diff --git a/src/kmk/config/dospaths.m4 b/src/kmk/config/dospaths.m4
new file mode 100644
index 0000000..9aa9814
--- /dev/null
+++ b/src/kmk/config/dospaths.m4
@@ -0,0 +1,33 @@
+# Test if the system uses DOS-style pathnames (drive specs and backslashes)
+# By Paul Smith <psmith@gnu.org>. Based on dos.m4 by Jim Meyering.
+#
+# Copyright (C) 1993-2016 Free Software Foundation, Inc.
+# This file is part of GNU Make.
+#
+# GNU Make is free software; you can redistribute it and/or modify it under
+# the terms of the GNU General Public License as published by the Free Software
+# Foundation; either version 3 of the License, or (at your option) any later
+# version.
+#
+# GNU Make is distributed in the hope that it will be useful, but WITHOUT ANY
+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
+# details.
+#
+# You should have received a copy of the GNU General Public License along with
+# this program. If not, see <http://www.gnu.org/licenses/>.
+
+AC_DEFUN([pds_AC_DOS_PATHS], [
+ AC_CACHE_CHECK([whether system uses MSDOS-style paths], [ac_cv_dos_paths], [
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+#if !defined _WIN32 && !defined __WIN32__ && !defined __MSDOS__ && !defined __EMX__ && !defined __MSYS__ && !defined __CYGWIN__
+neither MSDOS nor Windows nor OS2
+#endif
+]])],
+ [ac_cv_dos_paths=yes],
+ [ac_cv_dos_paths=no])])
+
+ AS_IF([test x"$ac_cv_dos_paths" = xyes],
+ [ AC_DEFINE_UNQUOTED([HAVE_DOS_PATHS], 1,
+ [Define if the system uses DOS-style pathnames.])])
+])