summaryrefslogtreecommitdiffstats
path: root/src/kmk/tests/scripts/misc/fopen-fail
diff options
context:
space:
mode:
Diffstat (limited to 'src/kmk/tests/scripts/misc/fopen-fail')
-rw-r--r--src/kmk/tests/scripts/misc/fopen-fail18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/kmk/tests/scripts/misc/fopen-fail b/src/kmk/tests/scripts/misc/fopen-fail
new file mode 100644
index 0000000..2ec9810
--- /dev/null
+++ b/src/kmk/tests/scripts/misc/fopen-fail
@@ -0,0 +1,18 @@
+# -*-perl-*-
+
+$description = "Make sure make exits with an error if fopen fails.";
+
+# Recurse infinitely until we run out of open files, and ensure we
+# fail with a non-zero exit code. Don't bother to test the output
+# since it's hard to know what it will be, exactly.
+# See Savannah bug #27374.
+
+# Use a longer-than-normal timeout: some systems have more FDs available?
+# We also set ulimit -n 512 in check-regression in Makefile.am, which see.
+# See Savannah bug #42390.
+run_make_test(q!
+include $(lastword $(MAKEFILE_LIST))
+!,
+ '', undef, 512, 300);
+
+1;