summaryrefslogtreecommitdiffstats
path: root/src/lib/kStuff/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/kStuff/Makefile.kmk')
-rw-r--r--src/lib/kStuff/Makefile.kmk55
1 files changed, 55 insertions, 0 deletions
diff --git a/src/lib/kStuff/Makefile.kmk b/src/lib/kStuff/Makefile.kmk
new file mode 100644
index 0000000..e06f67a
--- /dev/null
+++ b/src/lib/kStuff/Makefile.kmk
@@ -0,0 +1,55 @@
+# $Id: Makefile.kmk 29 2009-07-01 20:30:29Z bird $
+## @file
+# kStuff - Top-level makefile.
+#
+
+#
+# Copyright (c) 2006-2007 Knut St. Osmundsen <bird-kStuff-spamix@anduin.net>
+#
+# Permission is hereby granted, free of charge, to any person
+# obtaining a copy of this software and associated documentation
+# files (the "Software"), to deal in the Software without
+# restriction, including without limitation the rights to use,
+# copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following
+# conditions:
+#
+# The above copyright notice and this permission notice shall be
+# included in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+# OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+# OTHER DEALINGS IN THE SOFTWARE.
+#
+
+DEPTH = .
+include $(PATH_KBUILD)/subheader.kmk
+
+include $(PATH_SUB_CURRENT)/kCpu/Makefile.kmk
+include $(PATH_SUB_CURRENT)/kDbg/Makefile.kmk
+include $(PATH_SUB_CURRENT)/kErr/Makefile.kmk
+include $(PATH_SUB_CURRENT)/kLdr/Makefile.kmk
+include $(PATH_SUB_CURRENT)/kRdr/Makefile.kmk
+
+include $(PATH_SUB_CURRENT)/kHlp/Makefile.kmk
+ifn1of ($(KBUILD_TARGET), darwin)
+ include $(PATH_SUB_CURRENT)/kProfiler2/Makefile.kmk
+endif
+
+LIBRARIES += kStuffStatic
+kStuffStatic_TEMPLATE = kStuffLIB
+kStuffStatic_SOURCES = \
+ $(TARGET_kCpuStatic) \
+ $(TARGET_kDbgStatic) \
+ $(TARGET_kErrStatic) \
+ $(TARGET_kLdrStatic) \
+ $(TARGET_kRdrStatic)
+
+include $(PATH_KBUILD)/subfooter.kmk
+