summaryrefslogtreecommitdiffstats
path: root/src/lib/kStuff/kErr/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/kStuff/kErr/Makefile.kmk')
-rw-r--r--src/lib/kStuff/kErr/Makefile.kmk61
1 files changed, 61 insertions, 0 deletions
diff --git a/src/lib/kStuff/kErr/Makefile.kmk b/src/lib/kStuff/kErr/Makefile.kmk
new file mode 100644
index 0000000..de11e20
--- /dev/null
+++ b/src/lib/kStuff/kErr/Makefile.kmk
@@ -0,0 +1,61 @@
+# $Id: Makefile.kmk 29 2009-07-01 20:30:29Z bird $
+## @file
+# kErr - The Status Code API, sub-makefile.
+#
+
+#
+# Copyright (c) 2006-2007 Knut St. Osmundsen <bird-kStuff-spamix@anduin.net>
+#
+# Permission is hereby granted, free of charge, to any person
+# obtaining a copy of this software and associated documentation
+# files (the "Software"), to deal in the Software without
+# restriction, including without limitation the rights to use,
+# copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following
+# conditions:
+#
+# The above copyright notice and this permission notice shall be
+# included in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+# OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+# OTHER DEALINGS IN THE SOFTWARE.
+#
+
+DEPTH ?= ..
+SUB_DEPTH = ..
+include $(PATH_KBUILD)/subheader.kmk
+
+#
+# kHlpBaseStatic
+#
+LIBRARIES += kErrStatic
+kErrStatic_TEMPLATE = kStuffLIB
+kErrStatic_SOURCES = \
+ kErrName.c
+
+kErrName.c_DEPS = $(PATH_TARGET)/kErrNameConsts.h
+kErrName.c_INCS = $(PATH_TARGET)
+
+#
+# Generate case statements for kErrName().
+#
+$(PATH_TARGET)/kErrNameConsts.h: $(PATH_SUB_ROOT)/include/k/kErrors.h $(MAKEFILE_CURRENT) | $(call DIRDEP,$(PATH_TARGET))
+ $(RM) -f $@
+ $(SED) \
+ -e '/^#define *\(K[A-Z_]*ERR_[^ ()]*\) .*$$/!d' \
+ -e 's/^#define *\(K[A-Z_]*ERR_[^ ()]*\) .*$$/ERR_CONST(\1)/' \
+ -e '/K[A-Z_]*ERR_[A-Z0-9_]*BASE/d' \
+ -e '/K[A-Z_]*ERR_[A-Z0-9_]*END/d' \
+ $< > $@
+
+
+# Generate the rules
+include $(PATH_KBUILD)/subfooter.kmk
+