summaryrefslogtreecommitdiffstats
path: root/src/sed/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/sed/lib/Makefile.am')
-rw-r--r--src/sed/lib/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/sed/lib/Makefile.am b/src/sed/lib/Makefile.am
new file mode 100644
index 0000000..8bc60d4
--- /dev/null
+++ b/src/sed/lib/Makefile.am
@@ -0,0 +1,16 @@
+## Process this file with automake to produce Makefile.in
+noinst_LIBRARIES = libsed.a
+noinst_HEADERS = getopt.h utils.h obstack.h regex_.h regex_internal.h \
+ strverscmp.h stdbool_.h
+
+libsed_a_SOURCES = getopt1.c getopt.c utils.c
+
+EXTRA_DIST = memmove.c strerror.c regcomp.c regexec.c regex_internal.c
+
+AM_CPPFLAGS = -I$(top_srcdir)/lib -I$(top_srcdir)/intl -I$(top_srcdir) \
+ -I$(top_builddir)/lib -I$(top_builddir)/intl
+
+libsed_a_LIBADD = @LIBOBJS@ @ALLOCA@
+libsed_a_DEPENDENCIES = $(libsed_a_LIBADD)
+
+DISTCLEANFILES = regex.h stdbool.h