summaryrefslogtreecommitdiffstats
path: root/src/sed/sed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/sed/sed/Makefile.am')
-rw-r--r--src/sed/sed/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/sed/sed/Makefile.am b/src/sed/sed/Makefile.am
new file mode 100644
index 0000000..e2b5b9d
--- /dev/null
+++ b/src/sed/sed/Makefile.am
@@ -0,0 +1,18 @@
+## Process this file with automake to produce Makefile.in
+bin_PROGRAMS = sed
+
+localedir = $(datadir)/locale
+
+sed_SOURCES = sed.c compile.c execute.c regexp.c fmt.c mbcs.c
+noinst_HEADERS = sed.h
+
+AM_CPPFLAGS = -I$(top_srcdir)/lib -I$(top_srcdir)/intl \
+ -I$(top_srcdir) -I$(top_builddir)/lib \
+ -I$(top_builddir)/intl -DLOCALEDIR=\"$(localedir)\"
+
+sed_LDADD = ../lib/libsed.a @INTLLIBS@
+sed_DEPENDENCIES = ../lib/libsed.a
+
+$(PROGRAMS): $(LDADD)
+
+