summaryrefslogtreecommitdiffstats
path: root/tests/os2-implib/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'tests/os2-implib/Makefile.kmk')
-rw-r--r--tests/os2-implib/Makefile.kmk38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/os2-implib/Makefile.kmk b/tests/os2-implib/Makefile.kmk
new file mode 100644
index 0000000..ec43222
--- /dev/null
+++ b/tests/os2-implib/Makefile.kmk
@@ -0,0 +1,38 @@
+# $Id: Makefile.kmk 2413 2010-09-11 17:43:04Z bird $
+## @file
+# Tests - OS/2 import library.
+#
+
+#
+# Copyright (c) 2010 knut st. osmundsen <bird-kBuild-spamx@anduin.net>
+#
+# This file is part of kBuild.
+#
+# kBuild is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# kBuild is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with kBuild; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+#
+#
+
+
+DEPTH = ../..
+include $(PATH_KBUILD)/header.kmk
+ifeq ($(KBUILD_HOST),os2)
+
+LIBRARIES = os2-implib-1
+os2-implib-1_TOOL = GCC3OMF
+os2-implib-1_SOURCES = os2-implib.def
+
+endif
+include $(FILE_KBUILD_FOOTER)
+