summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:09:26 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 01:09:26 +0000
commite81d699c0a77ceb47893e68fb780305d1bf68cc5 (patch)
treea2a042e4261316cd6376170cdfec5ba49c853799 /debian
parentReleasing progress-linux version 1:2.0.27-1~progress7.99u1. (diff)
downloadkexec-tools-e81d699c0a77ceb47893e68fb780305d1bf68cc5.tar.xz
kexec-tools-e81d699c0a77ceb47893e68fb780305d1bf68cc5.zip
Merging debian version 1:2.0.27-1.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/328de8e00e298f00d7ba6b25dc3950147e9642e6.patch92
-rw-r--r--debian/patches/series1
3 files changed, 100 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 3a3af76..7129166 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+kexec-tools (1:2.0.27-1.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Apply upstream patch to fix build with binutils 2.41 (Closes: #1058433)
+
+ -- Sebastian Ramacher <sramacher@debian.org> Sat, 27 Apr 2024 14:49:56 +0200
+
kexec-tools (1:2.0.27-1~progress7.99u1) graograman-backports; urgency=medium
* Initial reupload to graograman-backports.
diff --git a/debian/patches/328de8e00e298f00d7ba6b25dc3950147e9642e6.patch b/debian/patches/328de8e00e298f00d7ba6b25dc3950147e9642e6.patch
new file mode 100644
index 0000000..4106b27
--- /dev/null
+++ b/debian/patches/328de8e00e298f00d7ba6b25dc3950147e9642e6.patch
@@ -0,0 +1,92 @@
+From 328de8e00e298f00d7ba6b25dc3950147e9642e6 Mon Sep 17 00:00:00 2001
+From: Michel Lind <salimma@fedoraproject.org>
+Date: Tue, 30 Jan 2024 04:14:31 -0600
+Subject: Fix building on x86_64 with binutils 2.41
+
+Newer versions of the GNU assembler (observed with binutils 2.41) will
+complain about the ".arch i386" in files assembled with "as --64",
+with the message "Error: 64bit mode not supported on 'i386'".
+
+Fix by moving ".arch i386" below the relevant ".code32" directive, so
+that the assembler is no longer expecting 64-bit instructions to be used
+by the time that the ".arch i386" directive is encountered.
+
+Based on similar iPXE fix:
+https://github.com/ipxe/ipxe/commit/6ca597eee
+
+Signed-off-by: Michel Lind <michel@michel-slm.name>
+Signed-off-by: Simon Horman <horms@kernel.org>
+---
+ purgatory/arch/i386/entry32-16-debug.S | 2 +-
+ purgatory/arch/i386/entry32-16.S | 2 +-
+ purgatory/arch/i386/entry32.S | 2 +-
+ purgatory/arch/i386/setup-x86.S | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/purgatory/arch/i386/entry32-16-debug.S b/purgatory/arch/i386/entry32-16-debug.S
+index 5167944d..12e11649 100644
+--- a/purgatory/arch/i386/entry32-16-debug.S
++++ b/purgatory/arch/i386/entry32-16-debug.S
+@@ -25,10 +25,10 @@
+ .globl entry16_debug_pre32
+ .globl entry16_debug_first32
+ .globl entry16_debug_old_first32
+- .arch i386
+ .balign 16
+ entry16_debug:
+ .code32
++ .arch i386
+ /* Compute where I am running at (assumes esp valid) */
+ call 1f
+ 1: popl %ebx
+diff --git a/purgatory/arch/i386/entry32-16.S b/purgatory/arch/i386/entry32-16.S
+index c051aab0..eace0958 100644
+--- a/purgatory/arch/i386/entry32-16.S
++++ b/purgatory/arch/i386/entry32-16.S
+@@ -20,10 +20,10 @@
+ #undef i386
+ .text
+ .globl entry16, entry16_regs
+- .arch i386
+ .balign 16
+ entry16:
+ .code32
++ .arch i386
+ /* Compute where I am running at (assumes esp valid) */
+ call 1f
+ 1: popl %ebx
+diff --git a/purgatory/arch/i386/entry32.S b/purgatory/arch/i386/entry32.S
+index f7a494f1..8ce9e316 100644
+--- a/purgatory/arch/i386/entry32.S
++++ b/purgatory/arch/i386/entry32.S
+@@ -20,10 +20,10 @@
+ #undef i386
+
+ .text
+- .arch i386
+ .globl entry32, entry32_regs
+ entry32:
+ .code32
++ .arch i386
+
+ /* Setup a gdt that should that is generally usefully */
+ lgdt %cs:gdt
+diff --git a/purgatory/arch/i386/setup-x86.S b/purgatory/arch/i386/setup-x86.S
+index 201bb2cb..a212eed4 100644
+--- a/purgatory/arch/i386/setup-x86.S
++++ b/purgatory/arch/i386/setup-x86.S
+@@ -21,10 +21,10 @@
+ #undef i386
+
+ .text
+- .arch i386
+ .globl purgatory_start
+ purgatory_start:
+ .code32
++ .arch i386
+
+ /* Load a gdt so I know what the segment registers are */
+ lgdt %cs:gdt
+--
+cgit 1.2.3-korg
+
diff --git a/debian/patches/series b/debian/patches/series
index cea08c4..da96656 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -7,3 +7,4 @@ linker-option.patch
powerpcspe_support.patch
vmcore-dmesg_man_page_fix.patch
systemd-support.patch
+328de8e00e298f00d7ba6b25dc3950147e9642e6.patch