summaryrefslogtreecommitdiffstats
path: root/kexec/arch/alpha
diff options
context:
space:
mode:
Diffstat (limited to 'kexec/arch/alpha')
-rw-r--r--kexec/arch/alpha/Makefile4
-rw-r--r--kexec/arch/alpha/include/arch/options.h20
2 files changed, 24 insertions, 0 deletions
diff --git a/kexec/arch/alpha/Makefile b/kexec/arch/alpha/Makefile
new file mode 100644
index 0000000..4575d61
--- /dev/null
+++ b/kexec/arch/alpha/Makefile
@@ -0,0 +1,4 @@
+alpha_KEXEC_SRCS=
+dist += kexec/arch/alpha/Makefile kexec/arch/alpha/include/arch/options.h
+ $(alpha_KEXEC_SRCS)
+
diff --git a/kexec/arch/alpha/include/arch/options.h b/kexec/arch/alpha/include/arch/options.h
new file mode 100644
index 0000000..a012c8a
--- /dev/null
+++ b/kexec/arch/alpha/include/arch/options.h
@@ -0,0 +1,20 @@
+#ifndef KEXEC_ARCH_ALPHA_OPTIONS_H
+#define KEXEC_ARCH_ALPHA_OPTIONS_H
+
+#define OPT_ARCH_MAX (OPT_MAX+0)
+
+/* Options relevant to the architecture (excluding loader-specific ones),
+ * in this case none:
+ */
+#define KEXEC_ARCH_OPTIONS \
+ KEXEC_OPTIONS \
+
+#define KEXEC_ARCH_OPT_STR KEXEC_OPT_STR ""
+
+/* See the other architectures for details of these; Alpha has no
+ * loader-specific options yet.
+ */
+#define KEXEC_ALL_OPTIONS KEXEC_ARCH_OPTIONS
+#define KEXEC_ALL_OPT_STR KEXEC_ARCH_OPT_STR
+
+#endif /* KEXEC_ARCH_ALPHA_OPTIONS_H */