summaryrefslogtreecommitdiffstats
path: root/kexec/libfdt/Makefile.libfdt
diff options
context:
space:
mode:
Diffstat (limited to 'kexec/libfdt/Makefile.libfdt')
-rw-r--r--kexec/libfdt/Makefile.libfdt13
1 files changed, 13 insertions, 0 deletions
diff --git a/kexec/libfdt/Makefile.libfdt b/kexec/libfdt/Makefile.libfdt
new file mode 100644
index 0000000..9a2b4f7
--- /dev/null
+++ b/kexec/libfdt/Makefile.libfdt
@@ -0,0 +1,13 @@
+# Makefile.libfdt
+#
+# This is not a complete Makefile of itself. Instead, it is designed to
+# be easily embeddable into other systems of Makefiles.
+#
+LIBFDT_INCLUDES = fdt.h libfdt.h
+LIBFDT_SRCS = fdt.c fdt_ro.c fdt_wip.c fdt_sw.c fdt_rw.c fdt_strerror.c
+LIBFDT_OBJS = $(LIBFDT_SRCS:%.c=%.o)
+
+dist += kexec/libfdt/Makefile.libfdt \
+ kexec/libfdt/fdt.h kexec/libfdt/libfdt.h \
+ kexec/libfdt/libfdt_env.h \
+ kexec/libfdt/libfdt_internal.h