summaryrefslogtreecommitdiffstats
path: root/git-rm-for-kernel.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:06:04 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:06:04 +0000
commit2f0649f6fe411d7e07c8d56cf8ea56db53536da8 (patch)
tree778611fb52176dce1ad06c68e87b2cb348ca0f7b /git-rm-for-kernel.sh
parentInitial commit. (diff)
downloadklibc-2f0649f6fe411d7e07c8d56cf8ea56db53536da8.tar.xz
klibc-2f0649f6fe411d7e07c8d56cf8ea56db53536da8.zip
Adding upstream version 2.0.13.upstream/2.0.13upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'git-rm-for-kernel.sh')
-rwxr-xr-xgit-rm-for-kernel.sh17
1 files changed, 17 insertions, 0 deletions
diff --git a/git-rm-for-kernel.sh b/git-rm-for-kernel.sh
new file mode 100755
index 0000000..395692d
--- /dev/null
+++ b/git-rm-for-kernel.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+if [ -z "$RM" ]; then
+ export RM='git rm -rf'
+fi
+
+nuke () {
+ find "$@" -print | sort -r | xargs -rt $RM
+}
+
+nuke README Kbuild Makefile defconfig klibc.spec.in *.sh
+nuke contrib klcc
+
+# These files are either not needed or provided from the
+# kernel tree
+nuke scripts/Kbuild.include scripts/Kbuild.install
+nuke scripts/Makefile.*
+nuke scripts/basic