summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:04:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:04:33 +0000
commit2a09cf4b3f9a3bf63f8040fd4bbbe0c83211fc53 (patch)
tree45893f8625916795f5aa2c8fe235e210f2198bcc /Makefile.am
parentReleasing progress-linux version 31+20240202-2~progress7.99u1. (diff)
downloadkmod-2a09cf4b3f9a3bf63f8040fd4bbbe0c83211fc53.tar.xz
kmod-2a09cf4b3f9a3bf63f8040fd4bbbe0c83211fc53.zip
Merging upstream version 32.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 11 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d21ad2..d37b56d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,7 +40,7 @@ AM_LDFLAGS = $(OUR_LDFLAGS)
# 6. If any interfaces have been removed or changed since the last public
# release, then set age to 0.
LIBKMOD_CURRENT=6
-LIBKMOD_REVISION=1
+LIBKMOD_REVISION=2
LIBKMOD_AGE=4
noinst_LTLIBRARIES = shared/libshared.la
@@ -111,9 +111,19 @@ install-exec-hook:
ln -sf $$so_img_rel_target_prefix$(rootlibdir)/$$so_img_name $(DESTDIR)$(libdir)/libkmod.so && \
mv $(DESTDIR)$(libdir)/libkmod.so.* $(DESTDIR)$(rootlibdir); \
fi
+if BUILD_TOOLS
+ for tool in insmod lsmod rmmod depmod modprobe modinfo; do \
+ $(LN_S) kmod $(DESTDIR)$(bindir)/$$tool; \
+ done
+endif
uninstall-hook:
rm -f $(DESTDIR)$(rootlibdir)/libkmod.so*
+if BUILD_TOOLS
+ for tool in insmod lsmod rmmod depmod modprobe modinfo; do \
+ rm -f $(DESTDIR)$(bindir)/$$tool; \
+ done
+endif
if BUILD_TOOLS
bin_PROGRAMS = tools/kmod
@@ -129,12 +139,6 @@ tools_kmod_SOURCES = \
tools/depmod.c tools/log.h tools/log.c \
tools/static-nodes.c
-if BUILD_EXPERIMENTAL
-tools_kmod_SOURCES += \
- tools/insert.c \
- tools/remove.c
-endif
-
tools_kmod_LDADD = \
shared/libshared.la \
libkmod/libkmod-internal.la
@@ -260,11 +264,6 @@ TESTSUITE = \
testsuite/test-dependencies testsuite/test-depmod \
testsuite/test-list
-if BUILD_EXPERIMENTAL
-TESTSUITE += \
- testsuite/test-tools
-endif
-
check_PROGRAMS = $(TESTSUITE)
TESTS = $(TESTSUITE)
@@ -307,11 +306,6 @@ testsuite_test_depmod_CPPFLAGS = $(TESTSUITE_CPPFLAGS)
testsuite_test_list_LDADD = $(TESTSUITE_LDADD)
testsuite_test_list_CPPFLAGS = $(TESTSUITE_CPPFLAGS)
-if BUILD_EXPERIMENTAL
-testsuite_test_tools_LDADD = $(TESTSUITE_LDADD)
-testsuite_test_tools_CPPFLAGS = $(TESTSUITE_CPPFLAGS)
-endif
-
testsuite-distclean:
$(RM) -r $(ROOTFS)
$(RM) testsuite/stamp-rootfs