summaryrefslogtreecommitdiffstats
path: root/modules/dnstap
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-05 04:15:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-05 04:15:14 +0000
commit3a88b081ec27c1aafdb3d20c8054d346a0fe12ad (patch)
tree0c5420a148abb96557d657cedd70005ff1e3ff21 /modules/dnstap
parentReleasing progress-linux version 5.7.2-1~progress7.99u1. (diff)
downloadknot-resolver-3a88b081ec27c1aafdb3d20c8054d346a0fe12ad.tar.xz
knot-resolver-3a88b081ec27c1aafdb3d20c8054d346a0fe12ad.zip
Merging upstream version 5.7.3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'modules/dnstap')
-rw-r--r--modules/dnstap/dnstap.c1
-rw-r--r--modules/dnstap/meson.build3
2 files changed, 2 insertions, 2 deletions
diff --git a/modules/dnstap/dnstap.c b/modules/dnstap/dnstap.c
index 7572667..07780fc 100644
--- a/modules/dnstap/dnstap.c
+++ b/modules/dnstap/dnstap.c
@@ -193,6 +193,7 @@ static int dnstap_log(kr_layer_t *ctx, enum dnstap_log_phase phase) {
m.socket_family = DNSTAP__SOCKET_FAMILY__INET6;
m.has_socket_family = true;
break;
+ default:;
}
}
diff --git a/modules/dnstap/meson.build b/modules/dnstap/meson.build
index e8a94bf..038bf3e 100644
--- a/modules/dnstap/meson.build
+++ b/modules/dnstap/meson.build
@@ -43,11 +43,10 @@ if build_dnstap
dnstap_mod = shared_module(
'dnstap',
dnstap_src,
- dependencies: [
+ dependencies: mod_deps + [
declare_dependency(sources: dnstap_pb),
libfstrm,
libprotobuf_c,
- libknot,
],
include_directories: mod_inc_dir,
name_prefix: '',