summaryrefslogtreecommitdiffstats
path: root/distro/pkg/deb/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-12 04:45:07 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-12 04:45:07 +0000
commit0335817ced71e8355806ea0445aa3b105a22364c (patch)
treedffe735f2668a4728d8567feaf7ccb2d73076bac /distro/pkg/deb/rules
parentAdding upstream version 3.3.9. (diff)
downloadknot-upstream.tar.xz
knot-upstream.zip
Adding upstream version 3.4.0.upstream/3.4.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'distro/pkg/deb/rules')
-rwxr-xr-xdistro/pkg/deb/rules6
1 files changed, 2 insertions, 4 deletions
diff --git a/distro/pkg/deb/rules b/distro/pkg/deb/rules
index 82cc34b..c5c81d0 100755
--- a/distro/pkg/deb/rules
+++ b/distro/pkg/deb/rules
@@ -36,11 +36,9 @@ BASE_VERSION := $(shell echo $(DEB_VERSION) | sed 's/^\([^.]\+\.[^.]\+\).*/\1/')
# invocation due to bug in dh-python's plugin_pyproject.py wheel unpack
export PYBUILD_SYSTEM = distutils
-
%:
dh $@ \
- --exclude=.la --exclude=example.com.zone \
- --with python3
+ --with python3
override_dh_auto_configure:
dh_auto_configure -- \
@@ -95,7 +93,7 @@ ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
endif
override_dh_missing:
- dh_missing --fail-missing
+ dh_missing --exclude=.la --fail-missing
override_dh_installchangelogs:
dh_installchangelogs NEWS