summaryrefslogtreecommitdiffstats
path: root/python/libknot/pyproject.toml.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 19:05:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 19:05:44 +0000
commitb045529c40c83601909dca7b76a53498e9a70f33 (patch)
tree88371572105933fd950676c07b3a12163a0c9de0 /python/libknot/pyproject.toml.in
parentInitial commit. (diff)
downloadknot-b045529c40c83601909dca7b76a53498e9a70f33.tar.xz
knot-b045529c40c83601909dca7b76a53498e9a70f33.zip
Adding upstream version 3.3.4.upstream/3.3.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'python/libknot/pyproject.toml.in')
-rw-r--r--python/libknot/pyproject.toml.in38
1 files changed, 38 insertions, 0 deletions
diff --git a/python/libknot/pyproject.toml.in b/python/libknot/pyproject.toml.in
new file mode 100644
index 0000000..355e667
--- /dev/null
+++ b/python/libknot/pyproject.toml.in
@@ -0,0 +1,38 @@
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"
+
+[project]
+name = "libknot"
+version = "@PACKAGE_VERSION@"
+description = "Python bindings for libknot"
+readme = "README.md"
+requires-python = ">=3.5"
+license = { text = "GPL-3.0" }
+authors = [
+ { name = "CZ.NIC, z.s.p.o.", email = "knot-dns@labs.nic.cz" },
+]
+classifiers = [
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "Intended Audience :: System Administrators",
+ "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+ "Programming Language :: Python :: 3",
+ "Topic :: Internet :: Name Service (DNS)",
+ "Topic :: Software Development :: Libraries",
+ "Topic :: System :: Systems Administration",
+]
+
+[project.urls]
+Documentation = "https://www.knot-dns.cz/documentation"
+Issues = "https://gitlab.nic.cz/knot/knot-dns/-/issues"
+Source = "https://gitlab.nic.cz/knot/knot-dns/-/tree/master/python/libknot"
+
+[tool.hatch.build]
+# don't filter by .gitignore
+ignore-vcs = true
+exclude = [
+ ".*",
+ "*.in",
+ "Makefile*",
+]