summaryrefslogtreecommitdiffstats
path: root/python/libknot
diff options
context:
space:
mode:
Diffstat (limited to 'python/libknot')
-rw-r--r--python/libknot/Makefile.in5
-rw-r--r--python/libknot/libknot/probe.py10
2 files changed, 8 insertions, 7 deletions
diff --git a/python/libknot/Makefile.in b/python/libknot/Makefile.in
index 06b1083..c93de6e 100644
--- a/python/libknot/Makefile.in
+++ b/python/libknot/Makefile.in
@@ -260,6 +260,8 @@ infodir = @infodir@
install_sh = @install_sh@
libbpf_CFLAGS = @libbpf_CFLAGS@
libbpf_LIBS = @libbpf_LIBS@
+libdbus_CFLAGS = @libdbus_CFLAGS@
+libdbus_LIBS = @libdbus_LIBS@
libdir = @libdir@
libdnssec_SONAME = @libdnssec_SONAME@
libdnssec_SOVERSION = @libdnssec_SOVERSION@
@@ -271,8 +273,6 @@ libfstrm_CFLAGS = @libfstrm_CFLAGS@
libfstrm_LIBS = @libfstrm_LIBS@
libidn2_CFLAGS = @libidn2_CFLAGS@
libidn2_LIBS = @libidn2_LIBS@
-libidn_CFLAGS = @libidn_CFLAGS@
-libidn_LIBS = @libidn_LIBS@
libknot_SONAME = @libknot_SONAME@
libknot_SOVERSION = @libknot_SOVERSION@
libknot_VERSION_INFO = @libknot_VERSION_INFO@
@@ -290,7 +290,6 @@ libprotobuf_c_CFLAGS = @libprotobuf_c_CFLAGS@
libprotobuf_c_LIBS = @libprotobuf_c_LIBS@
liburcu_CFLAGS = @liburcu_CFLAGS@
liburcu_LIBS = @liburcu_LIBS@
-liburcu_PKGCONFIG = @liburcu_PKGCONFIG@
libxdp_CFLAGS = @libxdp_CFLAGS@
libxdp_LIBS = @libxdp_LIBS@
libzscanner_SONAME = @libzscanner_SONAME@
diff --git a/python/libknot/libknot/probe.py b/python/libknot/libknot/probe.py
index e6f09db..37b2cdf 100644
--- a/python/libknot/libknot/probe.py
+++ b/python/libknot/libknot/probe.py
@@ -12,9 +12,9 @@ class KnotProbeDataProto(enum.IntEnum):
UDP = 0
TCP = 1
- QUIC = 3
- TLS = 4
- HTTPS = 5
+ QUIC = 2
+ TLS = 3
+ HTTPS = 4
class KnotProbeDataDNSHdr(ctypes.BigEndianStructure):
@@ -132,8 +132,10 @@ class KnotProbeData(ctypes.Structure):
string += COL("UDP", GRN)
elif self.proto == KnotProbeDataProto.TCP:
string += COL("TCP", RED)
- else:
+ elif self.proto == KnotProbeDataProto.QUIC:
string += COL("QUIC", ORG)
+ else:
+ string += COL("TLS", YELW)
if self.tcp_rtt > 0:
string += ", RTT %.2f ms" % (self.tcp_rtt / 1000)
string += "\n ID %u, " % self.query_hdr.id