summaryrefslogtreecommitdiffstats
path: root/xbmc/interfaces/legacy/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 18:07:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 18:07:22 +0000
commitc04dcc2e7d834218ef2d4194331e383402495ae1 (patch)
tree7333e38d10d75386e60f336b80c2443c1166031d /xbmc/interfaces/legacy/CMakeLists.txt
parentInitial commit. (diff)
downloadkodi-c04dcc2e7d834218ef2d4194331e383402495ae1.tar.xz
kodi-c04dcc2e7d834218ef2d4194331e383402495ae1.zip
Adding upstream version 2:20.4+dfsg.upstream/2%20.4+dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'xbmc/interfaces/legacy/CMakeLists.txt')
-rw-r--r--xbmc/interfaces/legacy/CMakeLists.txt76
1 files changed, 76 insertions, 0 deletions
diff --git a/xbmc/interfaces/legacy/CMakeLists.txt b/xbmc/interfaces/legacy/CMakeLists.txt
new file mode 100644
index 0000000..d92fc78
--- /dev/null
+++ b/xbmc/interfaces/legacy/CMakeLists.txt
@@ -0,0 +1,76 @@
+set(SOURCES AddonCallback.cpp
+ AddonClass.cpp
+ Addon.cpp
+ AddonUtils.cpp
+ CallbackFunction.cpp
+ CallbackHandler.cpp
+ Control.cpp
+ Dialog.cpp
+ DrmCryptoSession.cpp
+ File.cpp
+ InfoTagGame.cpp
+ InfoTagMusic.cpp
+ InfoTagPicture.cpp
+ InfoTagRadioRDS.cpp
+ InfoTagVideo.cpp
+ Keyboard.cpp
+ LanguageHook.cpp
+ ListItem.cpp
+ ModuleXbmc.cpp
+ ModuleXbmcgui.cpp
+ ModuleXbmcplugin.cpp
+ ModuleXbmcvfs.cpp
+ Monitor.cpp
+ Player.cpp
+ PlayList.cpp
+ Settings.cpp
+ String.cpp
+ Window.cpp
+ WindowDialog.cpp
+ WindowDialogMixin.cpp
+ WindowXML.cpp)
+
+set(HEADERS Addon.h
+ AddonCallback.h
+ AddonClass.h
+ AddonString.h
+ AddonUtils.h
+ Alternative.h
+ aojsonrpc.h
+ CallbackFunction.h
+ CallbackHandler.h
+ Control.h
+ Dialog.h
+ Dictionary.h
+ DrmCryptoSession.h
+ Exception.h
+ File.h
+ InfoTagGame.h
+ InfoTagMusic.h
+ InfoTagPicture.h
+ InfoTagRadioRDS.h
+ InfoTagVideo.h
+ Keyboard.h
+ LanguageHook.h
+ List.h
+ ListItem.h
+ ModuleXbmc.h
+ ModuleXbmcgui.h
+ ModuleXbmcplugin.h
+ ModuleXbmcvfs.h
+ Monitor.h
+ Player.h
+ PlayList.h
+ RenderCapture.h
+ Settings.h
+ Stat.h
+ swighelper.h
+ Tuple.h
+ Window.h
+ WindowDialog.h
+ WindowDialogMixin.h
+ WindowException.h
+ WindowInterceptor.h
+ WindowXML.h)
+
+core_add_library(legacy_interface)