summaryrefslogtreecommitdiffstats
path: root/xbmc/windowing/wayland/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 18:07:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 18:07:22 +0000
commitc04dcc2e7d834218ef2d4194331e383402495ae1 (patch)
tree7333e38d10d75386e60f336b80c2443c1166031d /xbmc/windowing/wayland/CMakeLists.txt
parentInitial commit. (diff)
downloadkodi-c04dcc2e7d834218ef2d4194331e383402495ae1.tar.xz
kodi-c04dcc2e7d834218ef2d4194331e383402495ae1.zip
Adding upstream version 2:20.4+dfsg.upstream/2%20.4+dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'xbmc/windowing/wayland/CMakeLists.txt')
-rw-r--r--xbmc/windowing/wayland/CMakeLists.txt67
1 files changed, 67 insertions, 0 deletions
diff --git a/xbmc/windowing/wayland/CMakeLists.txt b/xbmc/windowing/wayland/CMakeLists.txt
new file mode 100644
index 0000000..5628ed8
--- /dev/null
+++ b/xbmc/windowing/wayland/CMakeLists.txt
@@ -0,0 +1,67 @@
+# from ArchSetup.cmake
+set_source_files_properties(${WAYLAND_EXTRA_PROTOCOL_GENERATED_DIR}/wayland-extra-protocols.cpp
+ ${WAYLAND_EXTRA_PROTOCOL_GENERATED_DIR}/wayland-extra-protocols.hpp
+ PROPERTIES GENERATED TRUE)
+
+set(SOURCES Connection.cpp
+ OptionalsReg.cpp
+ Output.cpp
+ InputProcessorKeyboard.h
+ InputProcessorPointer.h
+ InputProcessorTouch.h
+ OSScreenSaverIdleInhibitUnstableV1.cpp
+ Registry.cpp
+ Seat.cpp
+ SeatInputProcessing.cpp
+ SeatSelection.cpp
+ ShellSurface.cpp
+ ShellSurfaceWlShell.cpp
+ ShellSurfaceXdgShell.cpp
+ ShellSurfaceXdgShellUnstableV6.cpp
+ Util.cpp
+ VideoSyncWpPresentation.cpp
+ ${WAYLAND_EXTRA_PROTOCOL_GENERATED_DIR}/wayland-extra-protocols.cpp
+ WindowDecorator.cpp
+ WinEventsWayland.cpp
+ WinSystemWayland.cpp
+ XkbcommonKeymap.cpp)
+
+set(HEADERS Connection.h
+ OptionalsReg.h
+ Output.h
+ InputProcessorKeyboard.cpp
+ InputProcessorPointer.cpp
+ InputProcessorTouch.cpp
+ OSScreenSaverIdleInhibitUnstableV1.h
+ Registry.h
+ Seat.h
+ SeatInputProcessing.h
+ SeatSelection.h
+ ShellSurface.h
+ ShellSurfaceWlShell.h
+ ShellSurfaceXdgShell.h
+ ShellSurfaceXdgShellUnstableV6.h
+ Signals.h
+ VideoSyncWpPresentation.h
+ ${WAYLAND_EXTRA_PROTOCOL_GENERATED_DIR}/wayland-extra-protocols.hpp
+ WindowDecorator.h
+ WinEventsWayland.h
+ WinSystemWayland.h
+ XkbcommonKeymap.h)
+
+if(EGL_FOUND)
+ list(APPEND SOURCES WinSystemWaylandEGLContext.cpp)
+ list(APPEND HEADERS WinSystemWaylandEGLContext.h)
+endif()
+
+if(OPENGL_FOUND)
+ list(APPEND SOURCES WinSystemWaylandEGLContextGL.cpp)
+ list(APPEND HEADERS WinSystemWaylandEGLContextGL.h)
+endif()
+if(OPENGLES_FOUND)
+ list(APPEND SOURCES WinSystemWaylandEGLContextGLES.cpp)
+ list(APPEND HEADERS WinSystemWaylandEGLContextGLES.h)
+endif()
+
+
+core_add_library(windowing_WAYLAND)