summaryrefslogtreecommitdiffstats
path: root/tools/EventClients/Clients/WiiRemote/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/EventClients/Clients/WiiRemote/CMakeLists.txt')
-rw-r--r--tools/EventClients/Clients/WiiRemote/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/EventClients/Clients/WiiRemote/CMakeLists.txt b/tools/EventClients/Clients/WiiRemote/CMakeLists.txt
new file mode 100644
index 0000000..8c797b2
--- /dev/null
+++ b/tools/EventClients/Clients/WiiRemote/CMakeLists.txt
@@ -0,0 +1,23 @@
+list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
+
+find_package(Bluetooth REQUIRED)
+find_package(CWiid REQUIRED)
+find_package(GLU REQUIRED)
+
+set(SOURCES CWIID_WiiRemote.cpp)
+
+set(HEADERS CWIID_WiiRemote.h)
+
+add_executable(${APP_NAME_LC}-wiiremote ${SOURCES} ${HEADERS})
+
+target_include_directories(${APP_NAME_LC}-wiiremote
+ PRIVATE ${BLUETOOTH_INCLUDE_DIRS}
+ ${CWIID_INCLUDE_DIRS})
+
+target_link_libraries(${APP_NAME_LC}-wiiremote
+ PRIVATE ${SYSTEM_LDFLAGS}
+ ${BLUETOOTH_LIBRARIES}
+ ${CWIID_LIBRARIES})
+
+target_compile_options(${APP_NAME_LC}-wiiremote PRIVATE ${ARCH_DEFINES})
+