summaryrefslogtreecommitdiffstats
path: root/xbmc/platform/freebsd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'xbmc/platform/freebsd/CMakeLists.txt')
-rw-r--r--xbmc/platform/freebsd/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/xbmc/platform/freebsd/CMakeLists.txt b/xbmc/platform/freebsd/CMakeLists.txt
new file mode 100644
index 0000000..9b8782f
--- /dev/null
+++ b/xbmc/platform/freebsd/CMakeLists.txt
@@ -0,0 +1,28 @@
+set(SOURCES ../linux/AppParamParserLinux.cpp
+ CPUInfoFreebsd.cpp
+ OptionalsReg.cpp
+ ../linux/OptionalsReg.cpp
+ ../linux/TimeUtils.cpp
+ MemUtils.cpp
+ PlatformFreebsd.cpp)
+
+set(HEADERS ../linux/AppParamParserLinux.cpp
+ CPUInfoFreebsd.h
+ OptionalsReg.h
+ ../linux/OptionalsReg.h
+ ../linux/TimeUtils.h
+ PlatformFreebsd.h)
+
+if(ALSA_FOUND)
+ list(APPEND SOURCES ../linux/FDEventMonitor.cpp)
+ list(APPEND HEADERS ../linux/FDEventMonitor.h)
+endif()
+
+if(DBUS_FOUND)
+ list(APPEND SOURCES ../linux/DBusMessage.cpp
+ ../linux/DBusUtil.cpp)
+ list(APPEND HEADERS ../linux/DBusMessage.h
+ ../linux/DBusUtil.h)
+endif()
+
+core_add_library(freebsdsupport)