summaryrefslogtreecommitdiffstats
path: root/xbmc/windowing/android/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'xbmc/windowing/android/CMakeLists.txt')
-rw-r--r--xbmc/windowing/android/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/xbmc/windowing/android/CMakeLists.txt b/xbmc/windowing/android/CMakeLists.txt
new file mode 100644
index 0000000..fd489d1
--- /dev/null
+++ b/xbmc/windowing/android/CMakeLists.txt
@@ -0,0 +1,18 @@
+set(SOURCES OSScreenSaverAndroid.cpp
+ WinEventsAndroid.cpp
+ WinSystemAndroid.cpp
+ AndroidUtils.cpp
+ VideoSyncAndroid.cpp)
+
+set(HEADERS OSScreenSaverAndroid.h
+ WinEventsAndroid.h
+ WinSystemAndroid.h
+ AndroidUtils.h
+ VideoSyncAndroid.h)
+
+if(OPENGLES_FOUND)
+ list(APPEND SOURCES WinSystemAndroidGLESContext.cpp)
+ list(APPEND HEADERS WinSystemAndroidGLESContext.h)
+endif()
+
+core_add_library(windowing_android)