summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 11:57:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 11:57:42 +0000
commite58102c63de2c3a8b32a85b5cb08626835c0558c (patch)
treef1cd9e68bbb4dd8d3e02fd1b1d90fcc5a2a3c75d /debian/rules
parentAdding upstream version 1.3. (diff)
downloadlib2geom-e58102c63de2c3a8b32a85b5cb08626835c0558c.tar.xz
lib2geom-e58102c63de2c3a8b32a85b5cb08626835c0558c.zip
Adding debian version 1.3-2.debian/1.3-2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f603be1
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/architecture.mk
+
+%:
+ dh $@ --buildsystem cmake+ninja
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -D2GEOM_BUILD_SHARED=ON \
+ -DCMAKE_SKIP_RPATH:BOOL=ON \
+
+execute_before_dh_auto_build:
+ # If ragel is present then this file will be rebuilt at build time.
+ # Restore the original file on clean if that's the case.
+ # https://bugs.debian.org/1048245
+ set -e; [ ! -e $(shell command -v ragel) ] || \
+ perl -MDebian::Debhelper::Dh_Lib=restore_file_on_clean \
+ -e 'restore_file_on_clean("src/2geom/svg-path-parser.cpp")'
+
+# needed to pass the tests, as without rpath somhow the tests can't find the library anymore
+override_dh_auto_test:
+ LD_LIBRARY_PATH=$(CURDIR)/obj-$(DEB_HOST_GNU_TYPE)/src/2geom dh_auto_test