summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules50
1 files changed, 50 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e4eb4b0
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,50 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+include /usr/share/dpkg/architecture.mk
+
+DPKG_EXPORT_BUILDFLAGS=1
+include /usr/share/dpkg/buildflags.mk
+
+COMMA = ,
+ifneq (,$(filter parallel=%,$(subst $(COMMA), ,$(DEB_BUILD_OPTIONS))))
+ NJOBS := -j $(subst parallel=,,$(filter parallel=%,$(subst $(COMMA), ,$(DEB_BUILD_OPTIONS))))
+endif
+
+%:
+ dh $@ --parallel --with autoreconf
+
+override_dh_autoreconf:
+ if [ ! -f README ]; then touch README; fi
+ dh_autoreconf
+
+override_dh_clean:
+ rm -f libcmis-0.6.pc
+ rm -f cmis-client.1
+ rm -f README
+ dh_clean
+
+override_dh_auto_configure:
+ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+ dh_auto_configure -- --disable-tests --disable-long-tests --disable-werror --disable-silent-rules
+else
+ dh_auto_configure -- --disable-long-tests --disable-werror --disable-silent-rules
+endif
+
+override_dh_auto_build:
+ $(MAKE) $(NJOBS)
+
+override_dh_auto_test:
+ $(MAKE) $(NJOBS) check
+
+override_dh_auto_install:
+ dh_auto_install
+ find debian -name "*mockup*so*" -exec rm -f {} \;