summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:45:25 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:45:25 +0000
commit0779334c7ef83d40fc0cef69b454a2c2e3b5ed57 (patch)
treedb4c81ea6e91d3bcb5c31f512dc16abdde6b3655 /debian/rules
parentAdding upstream version 1.14.0. (diff)
downloadlibfido2-0779334c7ef83d40fc0cef69b454a2c2e3b5ed57.tar.xz
libfido2-0779334c7ef83d40fc0cef69b454a2c2e3b5ed57.zip
Adding debian version 1.14.0-1.debian/1.14.0-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b6d5fec
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DUDEV_RULES_DIR=/lib/udev/rules.d \
+ -DCMAKE_BUILD_RPATH_USE_ORIGIN=ON
+
+override_dh_makeshlibs:
+ dh_makeshlibs -- -c4
+
+override_dh_auto_test:
+ debian/run-regression-tests.sh