summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:47:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:47:37 +0000
commit00e2eb4fd0266c5be01e3a527a66aaad5ab4b634 (patch)
treea6a58bd544eb0b76b9d3acc678ea88791acca045 /misc
parentInitial commit. (diff)
downloadlibixion-00e2eb4fd0266c5be01e3a527a66aaad5ab4b634.tar.xz
libixion-00e2eb4fd0266c5be01e3a527a66aaad5ab4b634.zip
Adding upstream version 0.19.0.upstream/0.19.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/libixion.spec.in76
1 files changed, 76 insertions, 0 deletions
diff --git a/misc/libixion.spec.in b/misc/libixion.spec.in
new file mode 100644
index 0000000..fb3fdea
--- /dev/null
+++ b/misc/libixion.spec.in
@@ -0,0 +1,76 @@
+%define _corename libixion
+%define _ver @VERSION@
+%define _pkgname %{_corename}_%{_ver}
+%define _apiver @IXION_API_VERSION@
+%define _libname %{_corename}-%{_apiver}
+
+Name: %{_corename}-0_4-0
+Version: %{_ver}
+Release: 1
+Url: http://gitorious.org/ixion
+License: MIT/X11
+Source: %{_pkgname}.tar.bz2
+Group: Development/Libraries/C and C++
+Summary: Threaded multi-target formula parser & interpreter
+BuildRoot: %{_tmppath}/%{name}-%{version}-build
+BuildRequires: gcc-c++, libstdc++-devel, pkg-config, coreutils, boost-devel
+BuildRequires: mdds-devel >= 0.5.4
+Requires: boost >= 1.39
+
+%description
+Ixion is a general purpose formula parser & interpreter that can calculate
+multiple named targets, or "cells".
+
+Authors:
+--------
+ Kohei Yoshida <kohei.yoshida@suse.com>
+
+%package devel
+License: MIT/X11
+Group: Development/Libraries/C and C++
+Summary: Threaded multi-target formula parser & interpreter
+
+%description devel
+Ixion is a general purpose formula parser & interpreter that can calculate
+multiple named targets, or "cells".
+
+Authors:
+--------
+ Kohei Yoshida <kohei.yoshida@suse.com>
+
+%prep
+%setup -q -n %{_pkgname}
+
+%build
+./autogen.sh --prefix=/usr --libdir=%_libdir
+make %{?_smp_mflags}
+
+%check
+make check
+
+%install
+make DESTDIR=$RPM_BUILD_ROOT install
+rm $RPM_BUILD_ROOT%_bindir/ixion-test
+rm $RPM_BUILD_ROOT%_libdir/%{_libname}.a
+rm $RPM_BUILD_ROOT%_libdir/%{_libname}.la
+
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root)
+%{_bindir}/ixion-parser
+%{_bindir}/ixion-sorter
+%{_libdir}/%{_libname}.so.*
+
+%files devel
+%defattr(-,root,root)
+%{_includedir}/%{_libname}
+%{_libdir}/%{_libname}.so
+%{_libdir}/pkgconfig/%{_libname}.pc
+
+%changelog
+