summaryrefslogtreecommitdiffstats
path: root/internal/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'internal/meson.build')
-rw-r--r--internal/meson.build30
1 files changed, 30 insertions, 0 deletions
diff --git a/internal/meson.build b/internal/meson.build
new file mode 100644
index 0000000..744f83e
--- /dev/null
+++ b/internal/meson.build
@@ -0,0 +1,30 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+#
+# This file is part of libnvme.
+# Copyright (c) 2022 Dell Inc.
+#
+# Authors: Martin Belanger <Martin.Belanger@dell.com>
+#
+# Because libnvme is used as a subproject of nvme-cli,
+# the config.h file must be generated as a private file
+# hidden from nvme-cli.
+
+config_h = configure_file(
+ output: 'config.h',
+ configuration: conf
+)
+
+internal_incdir = include_directories('.')
+
+config_dep = declare_dependency(
+ include_directories : internal_incdir,
+ sources: config_h)
+
+config_h_path = meson.current_build_dir() / 'config.h'
+
+add_project_arguments(
+ [
+ '-include', config_h_path,
+ ],
+ language : 'c',
+)