summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:38:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:38:24 +0000
commit9199faea097ed81e2f836d5f60179bf6e51d5a40 (patch)
tree8fd938e444f5c1e9b4a9050a383f0493b2042ddb /debian/rules
parentAdding upstream version 6.338.2. (diff)
downloadlibplacebo-9199faea097ed81e2f836d5f60179bf6e51d5a40.tar.xz
libplacebo-9199faea097ed81e2f836d5f60179bf6e51d5a40.zip
Adding debian version 6.338.2-2.debian/6.338.2-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..78bf6fd
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,12 @@
+#! /usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- -Dtests=true -Ddemos=false
+
+override_dh_auto_test:
+ dh_auto_test -- -t 100