summaryrefslogtreecommitdiffstats
path: root/tools/glsl_preproc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tools/glsl_preproc/meson.build')
-rw-r--r--tools/glsl_preproc/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/glsl_preproc/meson.build b/tools/glsl_preproc/meson.build
new file mode 100644
index 0000000..677ef7c
--- /dev/null
+++ b/tools/glsl_preproc/meson.build
@@ -0,0 +1,13 @@
+strip_arg = get_option('debug') ? [] : [ '--strip' ]
+glsl_preproc = [ python, join_paths(meson.current_source_dir(), 'main.py') ] + \
+ strip_arg + [ '@INPUT@', '@OUTPUT@' ]
+glsl_deps = files(
+ 'macros.py',
+ 'statement.py',
+ 'templates.py',
+ 'templates/call.c.j2',
+ 'templates/function.c.j2',
+ 'templates/glsl_block.c.j2',
+ 'templates/struct.c.j2',
+ 'variables.py',
+)