summaryrefslogtreecommitdiffstats
path: root/.packit.yaml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 16:08:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 16:08:34 +0000
commit18de2315ea5ebdbb9e7537d2d472358107578d53 (patch)
tree698563a9c4f388e351185cd8cf98c3f3060676e7 /.packit.yaml
parentInitial commit. (diff)
downloadlibpod-18de2315ea5ebdbb9e7537d2d472358107578d53.tar.xz
libpod-18de2315ea5ebdbb9e7537d2d472358107578d53.zip
Adding upstream version 4.9.3+ds1.upstream/4.9.3+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.packit.yaml')
-rw-r--r--.packit.yaml79
1 files changed, 79 insertions, 0 deletions
diff --git a/.packit.yaml b/.packit.yaml
new file mode 100644
index 0000000..4ee1ab7
--- /dev/null
+++ b/.packit.yaml
@@ -0,0 +1,79 @@
+---
+# See the documentation for more information:
+# https://packit.dev/docs/configuration/
+
+specfile_path: rpm/podman.spec
+upstream_tag_template: v{version}
+
+srpm_build_deps:
+ - git-archive-all
+ - make
+
+actions:
+ fix-spec-file:
+ - "bash .packit.sh"
+
+jobs:
+ - job: copr_build
+ trigger: pull_request
+ notifications:
+ failure_comment:
+ message: "Ephemeral COPR build failed. @containers/packit-build please check."
+ enable_net: true
+ targets:
+ - fedora-all-x86_64
+ - fedora-all-aarch64
+ - fedora-eln-x86_64
+ - fedora-eln-aarch64
+ - centos-stream+epel-next-8-x86_64
+ - centos-stream+epel-next-8-aarch64
+ - centos-stream+epel-next-9-x86_64
+ - centos-stream+epel-next-9-aarch64
+ additional_repos:
+ - "copr://rhcontainerbot/podman-next"
+
+ # Run on commit to main branch
+ - job: copr_build
+ trigger: commit
+ notifications:
+ failure_comment:
+ message: "podman-next COPR build failed. @containers/packit-build please check."
+ branch: main
+ owner: rhcontainerbot
+ project: podman-next
+ enable_net: true
+
+ - job: tests
+ identifier: cockpit-revdeps
+ trigger: pull_request
+ notifications:
+ failure_comment:
+ message: "Cockpit tests failed for commit {commit_sha}. @martinpitt, @jelly, @mvollmer please check."
+ targets:
+ - fedora-latest-stable
+ - fedora-development
+ tf_extra_params:
+ environments:
+ - artifacts:
+ - type: repository-file
+ id: https://copr.fedorainfracloud.org/coprs/g/cockpit/main-builds/repo/fedora-$releasever/group_cockpit-main-builds-fedora-$releasever.repo
+ - type: repository-file
+ id: https://copr.fedorainfracloud.org/coprs/rhcontainerbot/podman-next/repo/fedora-$releasever/rhcontainerbot-podman-next-fedora-$releasever.repo
+ tmt:
+ context:
+ revdeps: "yes"
+
+ - job: propose_downstream
+ trigger: release
+ update_release: false
+ dist_git_branches: &stable_fedora
+ - fedora-39
+ - fedora-38
+
+ - job: koji_build
+ trigger: commit
+ dist_git_branches: *stable_fedora
+
+ - job: bodhi_update
+ trigger: commit
+ dist_git_branches: *stable_fedora