summaryrefslogtreecommitdiffstats
path: root/avmedia/Module_avmedia.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /avmedia/Module_avmedia.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'avmedia/Module_avmedia.mk')
-rw-r--r--avmedia/Module_avmedia.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/avmedia/Module_avmedia.mk b/avmedia/Module_avmedia.mk
new file mode 100644
index 0000000000..8a11320772
--- /dev/null
+++ b/avmedia/Module_avmedia.mk
@@ -0,0 +1,48 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,avmedia))
+
+$(eval $(call gb_Module_add_targets,avmedia,\
+ Library_avmedia \
+))
+
+ifneq (,$(filter AVMEDIA,$(BUILD_TYPE)))
+
+$(eval $(call gb_Module_add_l10n_targets,avmedia,\
+ AllLangMoTarget_avmedia \
+))
+
+ifeq ($(ENABLE_GSTREAMER_1_0),TRUE)
+$(eval $(call gb_Module_add_targets,avmedia,\
+ Library_avmediagst \
+))
+endif
+
+ifneq ($(ENABLE_GTK4),)
+$(eval $(call gb_Module_add_targets,avmedia,\
+ Library_avmediagtk \
+))
+endif
+
+ifeq ($(OS),MACOSX)
+$(eval $(call gb_Module_add_targets,avmedia,\
+ Library_avmediaMacAVF \
+))
+endif
+
+ifeq ($(OS),WNT)
+$(eval $(call gb_Module_add_targets,avmedia,\
+ Library_avmediawin \
+))
+endif
+
+endif # AVMEDIA
+
+# vim: set noet sw=4 ts=4: