summaryrefslogtreecommitdiffstats
path: root/basegfx/CppunitTest_basegfx.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /basegfx/CppunitTest_basegfx.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'basegfx/CppunitTest_basegfx.mk')
-rw-r--r--basegfx/CppunitTest_basegfx.mk51
1 files changed, 51 insertions, 0 deletions
diff --git a/basegfx/CppunitTest_basegfx.mk b/basegfx/CppunitTest_basegfx.mk
new file mode 100644
index 0000000000..219025e8e3
--- /dev/null
+++ b/basegfx/CppunitTest_basegfx.mk
@@ -0,0 +1,51 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,basegfx))
+
+$(eval $(call gb_CppunitTest_use_external,basegfx,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,basegfx))
+
+$(eval $(call gb_CppunitTest_use_libraries,basegfx,\
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,basegfx,\
+ basegfx/test/B2DRangeTest \
+ basegfx/test/B2IRangeTest \
+ basegfx/test/B2DPolyRangeTest \
+ basegfx/test/B2DHomMatrixTest \
+ basegfx/test/B2DPointTest \
+ basegfx/test/B2DPolygonTest \
+ basegfx/test/B2DPolygonToolsTest \
+ basegfx/test/B2DPolyPolygonTest \
+ basegfx/test/B2DPolyPolygonCutterTest \
+ basegfx/test/B2DSizeTest \
+ basegfx/test/B1DRangeTest \
+ basegfx/test/B2XRangeTest \
+ basegfx/test/B2IBoxTest \
+ basegfx/test/B2DTupleTest \
+ basegfx/test/B3DTupleTest \
+ basegfx/test/BColorModifierTest \
+ basegfx/test/BColorTest \
+ basegfx/test/SvgPathImportExport \
+ basegfx/test/basegfx3d \
+ basegfx/test/boxclipper \
+ basegfx/test/basegfxtools \
+ basegfx/test/clipstate \
+ basegfx/test/genericclipper \
+ basegfx/test/VectorTest \
+))
+
+# vim: set noet sw=4 ts=4: