summaryrefslogtreecommitdiffstats
path: root/bridges/Jar_java_uno.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /bridges/Jar_java_uno.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'bridges/Jar_java_uno.mk')
-rw-r--r--bridges/Jar_java_uno.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/bridges/Jar_java_uno.mk b/bridges/Jar_java_uno.mk
new file mode 100644
index 0000000000..14be1adcc6
--- /dev/null
+++ b/bridges/Jar_java_uno.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Jar_Jar,java_uno))
+
+$(eval $(call gb_Jar_use_jars,java_uno,\
+ libreoffice \
+))
+
+$(eval $(call gb_Jar_set_manifest,java_uno,$(SRCDIR)/bridges/source/jni_uno/java/com/sun/star/bridges/jni_uno/manifest))
+
+$(eval $(call gb_Jar_set_packageroot,java_uno,com))
+
+$(eval $(call gb_Jar_add_manifest_classpath,java_uno,\
+ libreoffice.jar \
+ $(if $(filter MACOSX,$(OS)),../../Frameworks/,../) \
+))
+
+$(eval $(call gb_Jar_add_sourcefiles,java_uno,\
+ bridges/source/jni_uno/java/com/sun/star/bridges/jni_uno/JNI_info_holder \
+ bridges/source/jni_uno/java/com/sun/star/bridges/jni_uno/JNI_proxy \
+))
+
+# vim: set noet sw=4 ts=4: