summaryrefslogtreecommitdiffstats
path: root/chart2/CppunitTest_chart2_dialogs_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /chart2/CppunitTest_chart2_dialogs_test.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'chart2/CppunitTest_chart2_dialogs_test.mk')
-rw-r--r--chart2/CppunitTest_chart2_dialogs_test.mk76
1 files changed, 76 insertions, 0 deletions
diff --git a/chart2/CppunitTest_chart2_dialogs_test.mk b/chart2/CppunitTest_chart2_dialogs_test.mk
new file mode 100644
index 0000000000..bfbd0d3d37
--- /dev/null
+++ b/chart2/CppunitTest_chart2_dialogs_test.mk
@@ -0,0 +1,76 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitScreenShot,chart2_dialogs_test))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,chart2_dialogs_test, \
+ chart2/qa/unit/chart2-dialogs-test \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,chart2_dialogs_test))
+
+$(eval $(call gb_CppunitTest_set_include,chart2_dialogs_test,\
+ -I$(SRCDIR)/chart2/source/inc \
+ -I$(SRCDIR)/chart2/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,chart2_dialogs_test, \
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ drawinglayer \
+ editeng \
+ i18nlangtag \
+ i18nutil \
+ msfilter \
+ oox \
+ sal \
+ salhelper \
+ sax \
+ sfx \
+ sot \
+ svl \
+ svt \
+ svx \
+ svxcore \
+ test \
+ tl \
+ tk \
+ ucbhelper \
+ unotest \
+ utl \
+ vcl \
+ xo \
+))
+
+$(eval $(call gb_CppunitTest_use_external,chart2_dialogs_test,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,chart2_dialogs_test))
+
+$(eval $(call gb_CppunitTest_use_ure,chart2_dialogs_test))
+$(eval $(call gb_CppunitTest_use_vcl_non_headless_with_windows,chart2_dialogs_test))
+
+$(eval $(call gb_CppunitTest_use_rdb,chart2_dialogs_test,services))
+
+$(eval $(call gb_CppunitTest_use_configuration,chart2_dialogs_test))
+
+$(eval $(call gb_CppunitTest_use_uiconfigs,chart2_dialogs_test,\
+ modules/schart \
+ svx \
+))
+
+$(eval $(call gb_CppunitTest_use_packages,chart2_dialogs_test,\
+ extras_palettes \
+))
+
+# vim: set noet sw=4 ts=4: