summaryrefslogtreecommitdiffstats
path: root/cli_ure/Library_cli_uno.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /cli_ure/Library_cli_uno.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'cli_ure/Library_cli_uno.mk')
-rw-r--r--cli_ure/Library_cli_uno.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/cli_ure/Library_cli_uno.mk b/cli_ure/Library_cli_uno.mk
new file mode 100644
index 0000000000..75eadae723
--- /dev/null
+++ b/cli_ure/Library_cli_uno.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,cli_uno))
+
+$(eval $(call gb_Library_add_ldflags,cli_uno,\
+ -ignore:4248 \
+))
+
+$(eval $(call gb_Library_use_udk_api,cli_uno))
+
+$(eval $(call gb_Library_use_libraries,cli_uno,\
+ cppu \
+ sal \
+))
+
+$(eval $(call gb_Library_use_system_win32_libs,cli_uno,\
+ mscoree \
+ msvcmrt \
+))
+
+$(eval $(call gb_Library_add_cxxclrobjects,cli_uno,\
+ cli_ure/source/uno_bridge/cli_bridge \
+ cli_ure/source/uno_bridge/cli_data \
+ cli_ure/source/uno_bridge/cli_environment \
+ cli_ure/source/uno_bridge/cli_proxy \
+ cli_ure/source/uno_bridge/cli_uno \
+))
+
+$(call gb_Library_get_headers_target,cli_uno) :| \
+ $(call gb_CliLibrary_get_target,cli_ure) \
+ $(call gb_CliUnoApi_get_target,cli_uretypes)
+
+# vim: set noet sw=4 ts=4: