summaryrefslogtreecommitdiffstats
path: root/cli_ure/Module_cli_ure.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /cli_ure/Module_cli_ure.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'cli_ure/Module_cli_ure.mk')
-rw-r--r--cli_ure/Module_cli_ure.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/cli_ure/Module_cli_ure.mk b/cli_ure/Module_cli_ure.mk
new file mode 100644
index 0000000000..ba18aecd1e
--- /dev/null
+++ b/cli_ure/Module_cli_ure.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,cli_ure))
+
+ifeq ($(COM),MSC)
+ifneq ($(CPUNAME)_$(CROSS_COMPILING),AARCH64_TRUE)
+$(eval $(call gb_Module_add_targets,cli_ure,\
+ CliLibrary_cli_basetypes \
+ CliLibrary_cli_ure \
+ CliNativeLibrary_cli_cppuhelper \
+ CliUnoApi_cli_uretypes \
+ CustomTarget_cli_ure_assemblies \
+ Executable_climaker \
+ Library_cli_cppuhelper_native \
+ Library_cli_uno \
+ Package_cli_basetypes_copy \
+))
+endif
+endif
+
+# vim: set noet sw=4 ts=4: