summaryrefslogtreecommitdiffstats
path: root/comphelper/CppunitTest_comphelper_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /comphelper/CppunitTest_comphelper_test.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'comphelper/CppunitTest_comphelper_test.mk')
-rw-r--r--comphelper/CppunitTest_comphelper_test.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/comphelper/CppunitTest_comphelper_test.mk b/comphelper/CppunitTest_comphelper_test.mk
new file mode 100644
index 0000000000..17de701aca
--- /dev/null
+++ b/comphelper/CppunitTest_comphelper_test.mk
@@ -0,0 +1,47 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,comphelper_test))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,comphelper_test, \
+ comphelper/qa/string/test_string \
+ comphelper/qa/string/NaturalStringSortTest \
+ comphelper/qa/container/testifcontainer \
+ comphelper/qa/container/testifcontainer3 \
+ comphelper/qa/unit/test_hash \
+ comphelper/qa/unit/base64_test \
+ comphelper/qa/unit/propertyvalue \
+ comphelper/qa/unit/types_test \
+ comphelper/qa/unit/test_guards \
+ comphelper/qa/unit/test_traceevent \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,comphelper_test))
+$(eval $(call gb_CppunitTest_use_sdk_api,comphelper_test))
+
+$(eval $(call gb_CppunitTest_use_libraries,comphelper_test, \
+ comphelper \
+ cppuhelper \
+ cppu \
+ sal \
+ unotest \
+))
+
+ifeq ($(TLS),NSS)
+$(eval $(call gb_CppunitTest_use_externals,comphelper_test,\
+ plc4 \
+ nss3 \
+))
+endif
+
+$(eval $(call gb_CppunitTest_use_components,comphelper_test,\
+ i18npool/util/i18npool \
+))
+
+# vim: set noet sw=4 ts=4: