summaryrefslogtreecommitdiffstats
path: root/connectivity/Library_writer.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /connectivity/Library_writer.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'connectivity/Library_writer.mk')
-rw-r--r--connectivity/Library_writer.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/connectivity/Library_writer.mk b/connectivity/Library_writer.mk
new file mode 100644
index 0000000000..a653e5502d
--- /dev/null
+++ b/connectivity/Library_writer.mk
@@ -0,0 +1,48 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,writer))
+
+$(eval $(call gb_Library_set_componentfile,writer,connectivity/source/drivers/writer/writer,services))
+
+$(eval $(call gb_Library_use_external,writer,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,writer))
+
+$(eval $(call gb_Library_set_include,writer,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/connectivity/inc \
+ -I$(SRCDIR)/connectivity/source/inc \
+ -I$(WORKDIR)/YaccTarget/connectivity/source/parse \
+))
+
+$(eval $(call gb_Library_use_libraries,writer,\
+ cppu \
+ cppuhelper \
+ svl \
+ tl \
+ utl \
+ sal \
+ salhelper \
+ dbtools \
+ file \
+ comphelper \
+))
+
+$(eval $(call gb_Library_add_exception_objects,writer,\
+ connectivity/source/drivers/writer/WCatalog \
+ connectivity/source/drivers/writer/WConnection \
+ connectivity/source/drivers/writer/WDatabaseMetaData \
+ connectivity/source/drivers/writer/WDriver \
+ connectivity/source/drivers/writer/WTable \
+ connectivity/source/drivers/writer/WTables \
+))
+
+# vim: set noet sw=4 ts=4: