summaryrefslogtreecommitdiffstats
path: root/cppuhelper/Module_cppuhelper.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /cppuhelper/Module_cppuhelper.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'cppuhelper/Module_cppuhelper.mk')
-rw-r--r--cppuhelper/Module_cppuhelper.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/cppuhelper/Module_cppuhelper.mk b/cppuhelper/Module_cppuhelper.mk
new file mode 100644
index 0000000000..35b95e5ab8
--- /dev/null
+++ b/cppuhelper/Module_cppuhelper.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,cppuhelper))
+
+$(eval $(call gb_Module_add_targets,cppuhelper,\
+ InternalUnoApi_cppuhelper \
+ Library_cppuhelper \
+ StaticLibrary_findsofficepath \
+))
+
+$(eval $(call gb_Module_add_check_targets,cppuhelper,\
+ CppunitTest_cppuhelper_cppu_ifcontainer \
+ CppunitTest_cppuhelper_cppu_unourl \
+ CppunitTest_cppuhelper_qa_misc \
+ CppunitTest_cppuhelper_qa_weak \
+))
+
+# vim: set noet sw=4 ts=4: