summaryrefslogtreecommitdiffstats
path: root/dbaccess/CppunitTest_dbaccess_firebird_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /dbaccess/CppunitTest_dbaccess_firebird_test.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dbaccess/CppunitTest_dbaccess_firebird_test.mk')
-rw-r--r--dbaccess/CppunitTest_dbaccess_firebird_test.mk76
1 files changed, 76 insertions, 0 deletions
diff --git a/dbaccess/CppunitTest_dbaccess_firebird_test.mk b/dbaccess/CppunitTest_dbaccess_firebird_test.mk
new file mode 100644
index 0000000000..a8d4704eb1
--- /dev/null
+++ b/dbaccess/CppunitTest_dbaccess_firebird_test.mk
@@ -0,0 +1,76 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,dbaccess_firebird_test))
+
+$(eval $(call gb_CppunitTest_use_external,dbaccess_firebird_test,boost_headers))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,dbaccess_firebird_test, \
+ dbaccess/qa/unit/firebird \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,dbaccess_firebird_test, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ dbaxml \
+ firebird_sdbc \
+ sal \
+ subsequenttest \
+ svt \
+ test \
+ tl \
+ unotest \
+ utl \
+ xo \
+))
+
+$(eval $(call gb_CppunitTest_use_api,dbaccess_firebird_test,\
+ offapi \
+ oovbaapi \
+ udkapi \
+))
+
+$(eval $(call gb_CppunitTest_use_ure,dbaccess_firebird_test))
+$(eval $(call gb_CppunitTest_use_vcl,dbaccess_firebird_test))
+
+$(eval $(call gb_CppunitTest_use_components,dbaccess_firebird_test,\
+ basic/util/sb \
+ comphelper/util/comphelp \
+ configmgr/source/configmgr \
+ connectivity/source/drivers/firebird/firebird_sdbc \
+ connectivity/source/manager/sdbc2 \
+ dbaccess/util/dba \
+ dbaccess/source/filter/xml/dbaxml \
+ dbaccess/util/dbu \
+ filter/source/config/cache/filterconfig1 \
+ framework/util/fwk \
+ i18npool/util/i18npool \
+ linguistic/source/lng \
+ package/source/xstor/xstor \
+ package/util/package2 \
+ sax/source/expatwrap/expwrap \
+ sfx2/util/sfx \
+ svl/source/fsstor/fsstorage \
+ svl/util/svl \
+ toolkit/util/tk \
+ ucb/source/core/ucb1 \
+ ucb/source/ucp/file/ucpfile1 \
+ unotools/util/utl \
+ uui/util/uui \
+ xmloff/util/xo \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,dbaccess_firebird_test))
+
+$(eval $(call gb_CppunitTest_use_uiconfigs,dbaccess_firebird_test, \
+ dbaccess \
+))
+
+# vim: set noet sw=4 ts=4: