summaryrefslogtreecommitdiffstats
path: root/dbaccess/Executable_odbcconfig.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /dbaccess/Executable_odbcconfig.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dbaccess/Executable_odbcconfig.mk')
-rw-r--r--dbaccess/Executable_odbcconfig.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/dbaccess/Executable_odbcconfig.mk b/dbaccess/Executable_odbcconfig.mk
new file mode 100644
index 0000000000..2156128469
--- /dev/null
+++ b/dbaccess/Executable_odbcconfig.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,odbcconfig))
+
+$(eval $(call gb_Executable_set_targettype_gui,odbcconfig,YES))
+
+$(eval $(call gb_Executable_use_libraries,odbcconfig,\
+ comphelper \
+))
+
+$(eval $(call gb_Library_use_sdk_api,odbcconfig))
+
+$(eval $(call gb_Executable_add_exception_objects,odbcconfig,\
+ dbaccess/win32/source/odbcconfig/odbcconfig \
+))
+
+$(eval $(call gb_Executable_add_default_nativeres,odbcconfig))
+
+# vim: set noet sw=4 ts=4: