summaryrefslogtreecommitdiffstats
path: root/dbaccess/Library_sdbt.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /dbaccess/Library_sdbt.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dbaccess/Library_sdbt.mk')
-rw-r--r--dbaccess/Library_sdbt.mk46
1 files changed, 46 insertions, 0 deletions
diff --git a/dbaccess/Library_sdbt.mk b/dbaccess/Library_sdbt.mk
new file mode 100644
index 0000000000..c6109b6e6c
--- /dev/null
+++ b/dbaccess/Library_sdbt.mk
@@ -0,0 +1,46 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,sdbt))
+
+$(eval $(call gb_Library_set_include,sdbt,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/dbaccess/inc/ \
+ -I$(SRCDIR)/dbaccess/source/inc/ \
+ -I$(SRCDIR)/dbaccess/source/sdbtools/inc \
+))
+
+$(eval $(call gb_Library_use_external,sdbt,boost_headers))
+
+$(eval $(call gb_Library_set_precompiled_header,sdbt,dbaccess/inc/pch/precompiled_sdbt))
+
+$(eval $(call gb_Library_use_sdk_api,sdbt))
+
+$(eval $(call gb_Library_use_libraries,sdbt,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ dba \
+ dbtools \
+ sal \
+ salhelper \
+ tl \
+ utl \
+))
+
+$(eval $(call gb_Library_set_componentfile,sdbt,dbaccess/util/sdbt,services))
+
+$(eval $(call gb_Library_add_exception_objects,sdbt,\
+ dbaccess/source/sdbtools/connection/connectiontools \
+ dbaccess/source/sdbtools/connection/datasourcemetadata \
+ dbaccess/source/sdbtools/connection/objectnames \
+ dbaccess/source/sdbtools/connection/tablename \
+))
+
+# vim: set noet sw=4 ts=4: