summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 09:46:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 09:48:54 +0000
commitbe7897864e9812d8dea97f260cac55e8a671895b (patch)
tree858160f3c08ff87dbe3b348b61e498391259e43a /debian/patches
parentMerging upstream version 4:24.2.2. (diff)
downloadlibreoffice-be7897864e9812d8dea97f260cac55e8a671895b.tar.xz
libreoffice-be7897864e9812d8dea97f260cac55e8a671895b.zip
Merging debian version 4:24.2.2-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/disable-java-in-odk-build-examples-on-zero-vm.diff2
-rw-r--r--debian/patches/pdfium-ports.diff42
-rw-r--r--debian/patches/python-3.12.diff120
-rw-r--r--debian/patches/series2
4 files changed, 165 insertions, 1 deletions
diff --git a/debian/patches/disable-java-in-odk-build-examples-on-zero-vm.diff b/debian/patches/disable-java-in-odk-build-examples-on-zero-vm.diff
index 72c4914bf9..d8309ba293 100644
--- a/debian/patches/disable-java-in-odk-build-examples-on-zero-vm.diff
+++ b/debian/patches/disable-java-in-odk-build-examples-on-zero-vm.diff
@@ -28,7 +28,7 @@ index 06398bfa99a7..06835ae884c4 100644
+ fi
fi
else
- AC_MSG_ERROR([Java not found. You need at least JDK 17])
+ AC_MSG_ERROR([Java not found. You need at least JDK 8])
@@ -7841,6 +7849,7 @@ else
JAVAIFLAGS=$JAVAIFLAGS_FOR_BUILD
fi
diff --git a/debian/patches/pdfium-ports.diff b/debian/patches/pdfium-ports.diff
new file mode 100644
index 0000000000..2f450f5e60
--- /dev/null
+++ b/debian/patches/pdfium-ports.diff
@@ -0,0 +1,42 @@
+--- a/external/pdfium/debian-ports.diff 2024-03-04 21:33:17.133064736 +0100
++++ b/external/pdfium/debian-ports.diff 2024-03-05 16:52:13.688932548 +0100
+@@ -0,0 +1,28 @@
++--- build/build_config.h 2024-03-05 16:50:08.624785549 +0100
+++++ build/build_config.h 2024-03-05 16:50:55.616839071 +0100
++@@ -350,6 +350,25 @@
++ #define ARCH_CPU_RISCV64 1
++ #define ARCH_CPU_64_BITS 1
++ #define ARCH_CPU_LITTLE_ENDIAN 1
+++#elif defined(__sparc__)
+++#define ARCH_CPU_BIG_ENDIAN 1
+++#if defined(__arch64__)
+++#define ARCH_CPU_64_BITS 1
+++#else
+++#define ARCH_CPU_32_BITS 1
+++#endif
+++#elif defined(__m68k__)
+++#define ARCH_CPU_32_BITS 1
+++#define ARCH_CPU_BIG_ENDIAN 1
+++#elif defined(__hppa__)
+++#define ARCH_CPU_32_BITS 1
+++#define ARCH_CPU_BIG_ENDIAN 1
+++#elif defined(__alpha__)
+++#define ARCH_CPU_64_BITS 1
+++#define ARCH_CPU_LITTLE_ENDIAN 1
+++#elif defined(__ia64__)
+++#define ARCH_CPU_64_BITS 1
+++#define ARCH_CPU_LITTLE_ENDIAN 1
++ #else
++ #error Please add support for your architecture in build/build_config.h
++ #endif
+--- a/external/pdfium/UnpackedTarball_pdfium.mk 2024-03-05 16:54:17.425089179 +0100
++++ b/external/pdfium/UnpackedTarball_pdfium.mk 2024-03-05 16:54:31.949108078 +0100
+@@ -18,6 +18,8 @@
+
+ pdfium_patches += system-abseil.diff
+
++pdfium_patches += debian-ports.diff
++
+ $(eval $(call gb_UnpackedTarball_UnpackedTarball,pdfium))
+
+ $(eval $(call gb_UnpackedTarball_set_tarball,pdfium,$(PDFIUM_TARBALL)))
diff --git a/debian/patches/python-3.12.diff b/debian/patches/python-3.12.diff
new file mode 100644
index 0000000000..40a341470c
--- /dev/null
+++ b/debian/patches/python-3.12.diff
@@ -0,0 +1,120 @@
+From 7a561440acd01949e9b7b4efef9062ce05ce5d64 Mon Sep 17 00:00:00 2001
+From: Justin Luth <jluth@mail.com>
+Date: Wed, 13 Mar 2024 08:38:40 -0400
+Subject: allow build with python 3.12.0: initialize new tp_watched
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This fixes the build failure after I updated Ubuntu 24.04 (alpha),
+which upgraded python 3.11.7 to python 3.12.0, causing the error:
+
+libreoffice/pyuno/source/module/pyuno_callable.cxx:249:1:
+error: missing initializer for member ‘_typeobject::tp_watched’
+[-Werror=missing-field-initializers]
+...
+
+I gleaned this information from a July 2023 commit for
+https://github.com/xbmc/xbmc/issues/23503
+
+tp_watched was added in upstream commit python/cpython@82ccbf6
+https://github.com/python/cpython/commit/82ccbf69a842db25d8117f1c41b47aa5b4ed96ab
+
+This change first appeared in Python v3.12.0a1
+
+Change-Id: If82ff1eb47d66d2669d90d6e00e0feff3c55b5ca
+Reviewed-on: https://gerrit.libreoffice.org/c/core/+/164775
+Tested-by: Jenkins
+Reviewed-by: Justin Luth <jluth@mail.com>
+Reviewed-by: Stephan Bergmann <stephan.bergmann@allotropia.de>
+Reviewed-on: https://gerrit.libreoffice.org/c/core/+/164785
+---
+ pyuno/source/module/pyuno.cxx | 3 +++
+ pyuno/source/module/pyuno_callable.cxx | 3 +++
+ pyuno/source/module/pyuno_iterator.cxx | 6 ++++++
+ pyuno/source/module/pyuno_runtime.cxx | 3 +++
+ pyuno/source/module/pyuno_struct.cxx | 3 +++
+ 5 files changed, 18 insertions(+)
+
+diff --git a/pyuno/source/module/pyuno.cxx b/pyuno/source/module/pyuno.cxx
+index bd4904d5f729..a589c72ba3bf 100644
+--- a/pyuno/source/module/pyuno.cxx
++++ b/pyuno/source/module/pyuno.cxx
+@@ -1667,6 +1667,9 @@ static PyTypeObject PyUNOType =
+ #pragma clang diagnostic pop
+ #endif
+ #endif
++#if PY_VERSION_HEX >= 0x030C00A1
++ , 0 // tp_watched
++#endif
+ #endif
+ #endif
+ };
+diff --git a/pyuno/source/module/pyuno_callable.cxx b/pyuno/source/module/pyuno_callable.cxx
+index f22de316b7de..8f19fc8eb654 100644
+--- a/pyuno/source/module/pyuno_callable.cxx
++++ b/pyuno/source/module/pyuno_callable.cxx
+@@ -244,6 +244,9 @@ static PyTypeObject PyUNO_callable_Type =
+ #pragma clang diagnostic pop
+ #endif
+ #endif
++#if PY_VERSION_HEX >= 0x030C00A1
++ , 0 // tp_watched
++#endif
+ #endif
+ #endif
+ };
+diff --git a/pyuno/source/module/pyuno_iterator.cxx b/pyuno/source/module/pyuno_iterator.cxx
+index 134f318a1017..2fc70a32fcff 100644
+--- a/pyuno/source/module/pyuno_iterator.cxx
++++ b/pyuno/source/module/pyuno_iterator.cxx
+@@ -177,6 +177,9 @@ static PyTypeObject PyUNO_iterator_Type =
+ #pragma clang diagnostic pop
+ #endif
+ #endif
++#if PY_VERSION_HEX >= 0x030C00A1
++ , 0 // tp_watched
++#endif
+ #endif
+ #endif
+ };
+@@ -323,6 +326,9 @@ static PyTypeObject PyUNO_list_iterator_Type =
+ #pragma clang diagnostic pop
+ #endif
+ #endif
++#if PY_VERSION_HEX >= 0x030C00A1
++ , 0 // tp_watched
++#endif
+ #endif
+ #endif
+ };
+diff --git a/pyuno/source/module/pyuno_runtime.cxx b/pyuno/source/module/pyuno_runtime.cxx
+index cb95e5a46dc1..91e971fdd582 100644
+--- a/pyuno/source/module/pyuno_runtime.cxx
++++ b/pyuno/source/module/pyuno_runtime.cxx
+@@ -139,6 +139,9 @@ static PyTypeObject RuntimeImpl_Type =
+ #pragma clang diagnostic pop
+ #endif
+ #endif
++#if PY_VERSION_HEX >= 0x030C00A1
++ , 0 // tp_watched
++#endif
+ #endif
+ #endif
+ };
+diff --git a/pyuno/source/module/pyuno_struct.cxx b/pyuno/source/module/pyuno_struct.cxx
+index c8fd7e987905..364f2776011a 100644
+--- a/pyuno/source/module/pyuno_struct.cxx
++++ b/pyuno/source/module/pyuno_struct.cxx
+@@ -354,6 +354,9 @@ static PyTypeObject PyUNOStructType =
+ #pragma clang diagnostic pop
+ #endif
+ #endif
++#if PY_VERSION_HEX >= 0x030C00A1
++ , 0 // tp_watched
++#endif
+ #endif
+ #endif
+ };
+--
+cgit v1.2.3 \ No newline at end of file
diff --git a/debian/patches/series b/debian/patches/series
index b25a3b7f78..2c12454c06 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -48,3 +48,5 @@ we-dont-have-the-needed-fonts.diff
adapt-for-new-carlito.diff
fix-system-abseil-build.diff
fix-riscv64-bridge.diff
+pdfium-ports.diff
+python-3.12.diff