summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 09:29:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 09:29:09 +0000
commitb6d11bc9cde5639b019a6468a57eec0b47dd9c0a (patch)
tree96e8337e3f4bb8674517deca4bb80b9ad11fb98c /debian/rules
parentMerging upstream version 4:24.2.1. (diff)
downloadlibreoffice-b6d11bc9cde5639b019a6468a57eec0b47dd9c0a.tar.xz
libreoffice-b6d11bc9cde5639b019a6468a57eec0b47dd9c0a.zip
Merging debian version 4:24.2.1-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules85
1 files changed, 58 insertions, 27 deletions
diff --git a/debian/rules b/debian/rules
index d1b4a19297..e4b1d00a4e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -84,7 +84,7 @@ lo_sources_ver=$(shell grep AC_INIT $(SOURCE_TREE)/configure.ac | grep documentf
# NOT in proper libreoffice-3-6 branch
# use ./g checkout -b tag-libreoffice-3.6.2.1 libreoffice-3.6.2.1
GIT_TAG=libreoffice-$(lo_sources_ver)
-GIT_BRANCH=libreoffice-24-2-0
+GIT_BRANCH=libreoffice-24-2-1
endif
ifeq "$(USE_SOURCE_TARBALLS)" "y"
lo_sources_ver=$(shell cat $(CURDIR)/sources.ver | cut -d= -f2)
@@ -104,7 +104,6 @@ BUILD_DEPS=\
bc,\
bison,\
bzip2,\
- diffutils, \
flex, \
fontforge-nox | fontforge, \
gperf,\
@@ -203,8 +202,7 @@ SYSTEM_STUFF += cairo
ifeq "$(ENABLE_GUI)" "y"
BUILD_PLASMA=y
# let's assume we won't ship two plasmas parallel..
-KF_VERSION=5
-PLASMA_VERSION=$(KF_VERSION)
+PLASMA_VERSION=5
ENABLE_QT5=n
#QT5_MINVER=
endif
@@ -236,7 +234,6 @@ DWZ_ARGS:=-L 100000000
endif
endif
SYSTEM_STUFF += xmlsec
-USE_SYSTEMD=n
SYSTEM_STUFF += zxcvbn
ifeq ($(filter noinsttest,$(DEB_BUILD_PROFILES)),)
@@ -265,6 +262,7 @@ ifeq "$(ENABLE_JAVA)" "y"
SYSTEM_STUFF += beanshell
SYSTEM_STUFF += hsqldb
endif
+ENABLE_LPSOLVE=y
SYSTEM_STUFF += lpsolve
USE_SHARED_LPSOLVE=y
#LPSOLVE_MIN_VERSION=
@@ -474,7 +472,8 @@ CONFIGURE_FLAGS+= \
--disable-fetch-external \
--without-fonts --enable-build-opensymbol \
--without-myspell-dicts \
- --with-branding=$(CURDIR)/debian/branding
+ --with-branding=$(CURDIR)/debian/branding \
+ --without-coredumpctl
ifeq "$(ENABLE_GUI)" "y"
BUILD_DEPS += ,\
@@ -536,6 +535,8 @@ RTL_ARCH := $(shell grep RTL_ARCH debian/vars.$(DEB_HOST_ARCH) | cut -d"=" -f2)
OOO_64BIT_ARCHS = $(filter alpha amd64 arm64 ia64 kfreebsd-amd64 loong64 mips64 mips64el ppc64 ppc64el riscv64 s390x sparc64, $(OOO_ARCHS))
$(eval $(call gen_no_archs,OOO_64BIT_ARCHS))
+OOO_32BIT_ARCHS = $(filter-out $(OOO_64BIT_ARCHS),$(OOO_ARCHS))
+$(eval $(call gen_no_archs,OOO_32BIT_ARCHS))
OOO_BE_ARCHS = $(filter hppa m68k mips mips64 powerpc powerpcspe ppc64 s390 s390x sparc sparc64,$(OOO_ARCHS))
$(eval $(call gen_no_archs,OOO_BE_ARCHS))
OOO_LE_ARCHS = $(filter-out $(OOO_BE_ARCHS),$(OOO_ARCHS))
@@ -625,8 +626,9 @@ endif
# Java...
# upstream says --source=1.8 / --target=1.8 so 1.8 is fine in runtime
JAVA_RUNTIME_BASELINE=8
+JAVA_BRIDGE_BROKEN_ARCHS:=ppc64el s390x armhf
ifeq "$(JDK)" "default"
-OOO_JAVA_ARCHS = $(filter-out ppc64el s390x armhf,$(filter $(OOO_ARCHS),$(java$(JAVA_RUNTIME_BASELINE)_architectures)))
+OOO_JAVA_ARCHS = $(filter-out $(JAVA_BRIDGE_BROKEN_ARCHS),$(filter $(OOO_ARCHS),$(java$(JAVA_RUNTIME_BASELINE)_architectures)))
else
OOO_JAVA_ARCHS = $(OOO_ARCHS)
endif
@@ -709,6 +711,7 @@ endif
# Debian Bookworm
BOOKWORM_BACKPORT=y
+ENABLE_KF6=n
CONFIGURE_FLAGS += $(foreach i, $(SYSTEM_STUFF),--with-system-$(i))
@@ -830,7 +833,10 @@ ifeq "$(DEB_HOST_ARCH)" "i386"
endif
endif
ifeq "$(DEB_HOST_ARCH)" "riscv64"
- # see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1039906#26
+ # see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1039906#26 (fixed)
+ # and it seems it the payloadNaN test actually passes with -O2 where it's
+ # unclear whether it actually is on hardware supporting it. Let's keep at
+ # -O0 for now and be sure it fails before shipping something broken
ifneq (noopt,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
DEB_BUILD_OPTIONS += noopt
endif
@@ -951,6 +957,9 @@ else
endif
ifneq (,$(filter xmlsec, $(SYSTEM_STUFF)))
BUILD_DEPS += , libxmlsec1-dev (>= 1.2.35)
+ ifneq ($(BOOKWORM_BACKPORT),y)
+ BUILD_DEPS += , libxmlsec1-dev (>= 1.2.39-5) [$(filter $(OOO_CHECK_FATAL_ARCHS),$(filter-out i386,$(OOO_32BIT_ARCHS)))] <!nocheck>
+ endif
endif
ifneq (,$(filter expat, $(SYSTEM_STUFF)))
BUILD_DEPS += , libexpat1-dev
@@ -1079,9 +1088,6 @@ endif
ifeq "$(RUN_MAKE_CHECK)" "y"
BUILD_DEPS_ARCH += , locales$(OOO_NO_CHECK_ARCHS) <!nocheck>
BUILD_DEPS_ARCH += , gdb$(OOO_NO_CHECK_ARCHS) <!nocheck>
- ifeq "$(USE_SYSTEMD)" "y"
- BUILD_DEPS_ARCH += , systemd$(OOO_NO_CHECK_ARCHS) <!nocheck>, systemd-coredump$(OOO_NO_CHECK_ARCHS) (>= 248) <!nocheck>, jq$(OOO_NO_CHECK_ARCHS) <!nocheck>
- endif
BUILD_DEPS_ARCH += , fontconfig [$(OOO_AUTOPKGTEST_ARCHS)] <!nocheck>
ifeq ($(BOOKWORM_BACKPORT),y)
BUILD_DEPS_ARCH += , fonts-liberation2 [$(OOO_AUTOPKGTEST_ARCHS)] <!nocheck>
@@ -1120,6 +1126,11 @@ endif
BUILD_DEPS_ARCH += , hunspell-en-us$(OOO_NO_CHECK_ARCHS) <!nocheck>
BUILD_DEPS_ARCH += , hyphen-en-us$(OOO_NO_CHECK_ARCHS) <!nocheck>
+ # for test_tdf159102_smart_justify_with_automatic_hyphenation.
+ # The test itself claims the test must not depend on the installed hyphenation patterns
+ # but installing this (which is suggested by writer as missing even after
+ # opening the .fodt) fixes it
+ BUILD_DEPS_ARCH += , hyphen-es$(OOO_NO_CHECK_ARCHS) <!nocheck>
endif
# we don't run any cppunit check in all builds
ifneq "$(AUTOPKGTEST_BUILD)" "y"
@@ -1128,7 +1139,7 @@ endif
# without the deterministic order patch the xmlsecurity_signing test fails. See
# https://cgit.freedesktop.org/libreoffice/core/commit/external/cppunit/order.patch.0?id=2f2246d22e2a8ccbc1dc3e6f5243734a61edf270
ifeq "$(ENABLE_LTO)" "y"
- BUILD_DEPS_ARCH += , libcppunit-dev (>= 1.15.1-4) [$(filter $(OOO_CHECK_ARCHS),$(OOO_64BIT_ARCHS))] <!nocheck>
+ BUILD_DEPS_ARCH += , libcppunit-dev (>= 1.15.1-4) [$(filter $(OOO_CHECK_ARCHS),$(OOO_ARCHS))] <!nocheck>
endif
endif
ifeq ($(MAKECMDGOALS),build-indep)
@@ -1165,7 +1176,7 @@ ifneq "$(BUILD_ONLY_EN_US)" "y"
# have gid_Module_Root.$iso
#ISOS=$(shell $(SOURCE_TREE)/bin/lo-xlate-lang -i all')
ISOS:=en-US af am ar as ast be bg bn bn-IN br bs ca ca-valencia cs cy da de dz el \
- en-GB en-ZA eo es et eu fa fi fr ga gd gl gu gug he hi hr hu id is it ja \
+ en-GB en-ZA eo es et eu fa fi fr ga gd gl gu gug he hi hr hu hy id is it ja \
ka kk km kmr-Latn kn ko lt lv mk mn ml mr nb ne nl nn nr nso oc om or \
pa-IN pl pt pt-BR ro ru rw si sk sl sr sr-Latn ss st sv szl \
ta te tg th tn tr ts ug uk uz ve vi xh zh-CN zh-TW zu
@@ -1178,7 +1189,7 @@ ifneq "$(BUILD_ONLY_EN_US)" "y"
endif
#LANGPACKISOS:=$(shell $(SOURCE_TREE)/bin/lo-xlate-lang -i all')
LANGPACKISOS:=en-US af am ar as ast be bg bn bn-IN br bs ca ca-valencia cs cy da de dz el \
- en-GB en-ZA eo es et eu fa fi fr ga gd gl gu gug he hi hr hu id is it ja \
+ en-GB en-ZA eo es et eu fa fi fr ga gd gl gu gug he hi hr hu hy id is it ja \
ka kk km kmr-Latn kn ko lt lv mk mn ml mr nb ne nl nn nr nso oc om or \
pa-IN pl pt pt-BR ro ru rw si sk sl sr sr-Latn ss st sv szl \
ta te tg th tn tr ts ug uk uz ve vi xh zh-CN zh-TW zu
@@ -1213,7 +1224,7 @@ ifeq "$(ENABLE_JAVA)" "y"
JAVA_HOME=/usr/lib/jvm/default-java
DEFAULT_JDK := $(call java_dependency, default-jdk)
# build-depend on 1.9 (upstream needs it anyway for module-info support)
- BUILD_DEPS += , $(shell echo $(DEFAULT_JDK) | sed -e 's/default-jdk/default-jdk (>= 2:1.17)/') <!nojava>
+ BUILD_DEPS += , $(shell echo $(DEFAULT_JDK) | sed -e 's/default-jdk/default-jdk (>= 2:1.17)/' | sed -e 's/\]/$(foreach i,$(JAVA_BRIDGE_BROKEN_ARCHS), !$(i))\]/') <!nojava>
endif
ifeq "$(JDK)" "openjdk"
BUILD_DEPS += , openjdk-$(JAVA_MAINVER)-jdk <!nojava>
@@ -1618,14 +1629,18 @@ ifeq "$(ENABLE_JAVA)" "y"
endif
endif
-ifneq (,$(filter lpsolve, $(SYSTEM_STUFF)))
- ifeq "$(USE_SHARED_LPSOLVE)" "y"
+ifeq ($(ENABLE_LPSOLVE),y)
+ ifneq (,$(filter lpsolve, $(SYSTEM_STUFF)))
+ ifeq "$(USE_SHARED_LPSOLVE)" "y"
BUILD_DEPS += , liblpsolve55-dev $(LPSOLVE_MIN_VERSION), lp-solve $(LPSOLVE_MIN_VERSION)
LPSOLVE_DEP = lp-solve $(LPSOLVE_MIN_VERSION)
- else
+ else
BUILD_DEPS += , liblpsolve55-dev $(LPSOLVE_MIN_VERSION)
- endif
+ endif
BUILD_DEPS += , libsuitesparse-dev $(SUITESPARSE_MIN_VERSION)
+ endif
+else
+ CONFIGURE_FLAGS += --disable-lpsolve
endif
ifeq "$(USE_DBUS)" "y"
@@ -2080,7 +2095,8 @@ ifeq "$(ENABLE_QT6)" "y"
cat debian/control.qt6.in >> debian/control.new
endif
ifeq "$(BUILD_PLASMA)" "y"
- cat debian/control.plasma.in >> debian/control.new
+ sed -e "s|@PLASMA_VERSION@|$(PLASMA_VERSION)|g" \
+ >> debian/control.new < debian/control.plasma.in
endif
cat debian/control.postgresql.in >> debian/control.new
ifeq "$(ENABLE_EVO2)" "y"
@@ -2135,9 +2151,6 @@ ifneq "$(ALLOW_CLANG)" "y"
else
perl -pi -e "s/(Build-Conflicts: .*)/\1,clang [$(filter-out $(OOO_CLANG_ARCHS),$(OOO_ARCHS))],/" debian/control.new
endif
-ifeq "$(USE_SYSTEMD)" "n"
- perl -pi -e "s/(Build-Conflicts: .*)/\1,systemd-coredump <!nocheck>,/" debian/control.new
-endif
$(PYTHON) debian/scripts/joinctrl.py < debian/control.new > debian/control.tmp
mv debian/control.tmp debian/control.new
@@ -2146,6 +2159,12 @@ endif
# match myspell-fi and libreoffice-soikko/-voikko
perl -pi -e 's/myspell-dictionary-fi/myspell-dictionary-fi | libreoffice-spellcheck-fi/' debian/control.new
perl -pi -e 's/hyphen-fi/hyphen-fi | libreoffice-hyphenation-fi/' debian/control.new
+ # similar for -l10n-tr and zemberek
+ perl -pi -e 's/myspell-dictionary-tr/myspell-dictionary-tr | libreoffice-spellcheck-tr/' debian/control.new
+ perl -pi -e 's/hyphen-tr/hyphen-tr | libreoffice-hyphenation-tr/' debian/control.new
+ # and for -l10n-fr and grammalecte
+ perl -pi -e 's/myspell-dictionary-fr/myspell-dictionary-fr | libreoffice-spellcheck-fr/' debian/control.new
+ perl -pi -e 's/hyphen-fr/hyphen-fr | libreoffice-hyphenation-fr/' debian/control.new
ifeq "$(USE_DBUS)" "y"
ifeq "$(ENABLE_BLUETOOTH)" "y"
@@ -2376,6 +2395,7 @@ endif
touch $@
check:
+ifneq (nocheck,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
ifneq (,$(filter $(DEB_HOST_ARCH),$(OOO_NO_BASE_ARCHS)))
patch -p1 < $(CURDIR)/debian/tests/patches/disable-db-tests.diff
endif
@@ -2517,6 +2537,7 @@ ifneq (nocheck,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
endif
endif
endif
+endif
install: $(STAMP_DIR)/install-common $(STAMP_DIR)/install-arch $(STAMP_DIR)/install-indep
@@ -2565,14 +2586,24 @@ ifeq "$(ENABLE_QT6)" "y"
debian/tmp/pkg/libreoffice-qt6/$(OODIR)/program
endif
ifeq "$(shell echo $(ENABLE_KF5)$(ENABLE_KF6) | grep -q y && echo true)" "true"
- mv debian/tmp/pkg/libreoffice-kde \
- debian/tmp/pkg/libreoffice-kf$(KF_VERSION)
ifeq "$(BUILD_PLASMA)" "y"
mkdir -p debian/tmp/pkg/libreoffice-plasma/$(OODIR)/program
- mv debian/tmp/pkg/libreoffice-kf5/$(OODIR)/program/libkf$(KF_VERSION)be1lo.so \
+ mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libkf$(PLASMA_VERSION)be1lo.so \
debian/tmp/pkg/libreoffice-plasma/$(OODIR)/program
+ # remove other ones maybe built by --enable-kfX
+ rm -f debian/tmp/pkg/libreoffice-kf5/$(OODIR)/libkf*be1lo.so
else
- rm -f debian/tmp/pkg/libreoffice-kf5/$(OODIR)/libkf$(KF_VERSION)be1lo.so
+ rm -f debian/tmp/pkg/libreoffice-kf5/$(OODIR)/libkf*be1lo.so
+endif
+ifeq "$(ENABLE_KF5)" "y"
+ mkdir -p debian/tmp/pkg/libreoffice-kf5/$(OODIR)/program
+ mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_kf5lo.so \
+ debian/tmp/pkg/libreoffice-kf5/$(OODIR)/program
+endif
+ifeq "$(ENABLE_KF6)" "y"
+ mkdir -p debian/tmp/pkg/libreoffice-kf6/$(OODIR)/program
+ mv debian/tmp/pkg/libreoffice-kde/$(OODIR)/program/libvclplug_kf6lo.so \
+ debian/tmp/pkg/libreoffice-kf6/$(OODIR)/program
endif
endif