summaryrefslogtreecommitdiffstats
path: root/debian/tests/slowcheck
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:55:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:55:35 +0000
commit0e05dd0e4d67d88ca51780dafe4029744269e6fa (patch)
treeb49073fa569d8d4fbcc7002cf4df72fa840780c1 /debian/tests/slowcheck
parentAdding upstream version 4:24.2.0. (diff)
downloadlibreoffice-0e05dd0e4d67d88ca51780dafe4029744269e6fa.tar.xz
libreoffice-0e05dd0e4d67d88ca51780dafe4029744269e6fa.zip
Adding debian version 4:24.2.0-1.debian/4%24.2.0-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/tests/slowcheck')
-rwxr-xr-xdebian/tests/slowcheck60
1 files changed, 60 insertions, 0 deletions
diff --git a/debian/tests/slowcheck b/debian/tests/slowcheck
new file mode 100755
index 0000000000..04e8573efd
--- /dev/null
+++ b/debian/tests/slowcheck
@@ -0,0 +1,60 @@
+#!/bin/bash
+# autopkgtest check: Run junit base tests against an installed version of LibreOffice
+# (c) 2021 Software in the Public Interest, Inc.
+# Authors: Rene Engelhard <rene@debian.org>
+
+set -e
+set -E
+
+SRCDIR=`pwd`
+CHECK_PARALLELISM=1
+if [ -n "$AUTOPKGTEST_TMP" ]; then
+ WORKDIR=`mktemp -q -d -p $AUTOPKGTEST_TMP`
+else
+ WORKDIR=`mktemp -q -d`
+fi
+
+function unapply() {
+ cd $SRCDIR
+ echo
+ echo "====== Unapplying the patches ======"
+ patch -p1 -R < ./debian/tests/patches/cppunit-standalone.diff
+}
+
+trap "unapply" ERR
+
+echo
+echo "====== Patching the tree to only build the unittests against an existing installation ======"
+patch -p1 < ./debian/tests/patches/cppunit-standalone.diff
+
+echo
+echo "====== Enabling core dumps ======"
+# yes, we want core dumps and stack traces
+ulimit -c unlimited || true
+
+echo
+echo "====== Starting slowcheck with ${CHECK_PARALLELISM} job ======"
+
+# hack, otherwise it fails
+mkdir -p $SRCDIR/instdir/program/.dir
+mkdir -p $SRCDIR/instdir/share/config/soffice.cfg/simpress/.dir
+mkdir -p $SRCDIR/instdir/share/config/soffice.cfg/modules/simpress/popupmenu/.dir
+mkdir -p $SRCDIR/instdir/share/config/soffice.cfg/modules/simpress/statusbar/.dir
+mkdir -p $SRCDIR/instdir/share/config/soffice.cfg/modules/simpress/toolbar/.dir
+mkdir -p $SRCDIR/instdir/share/config/soffice.cfg/modules/simpress/ui/.dir
+mkdir -p $SRCDIR/instdir/share/config/soffice.cfg/modules/simpress/menubar/.dir
+
+# all modules containing slowcheck
+export PARALLELISM=$CHECK_PARALLELISM
+for i in `grep slowcheck */*.mk | cut -d"/" -f1 | sort | uniq | xargs`; do
+ echo
+ echo "====== Running slowcheck in module $i ======"; \
+ cd $i && \
+ make -rk slowcheck \
+ INSTDIR=/usr/lib/libreoffice \
+ verbose=t; \
+ cd ..;\
+done
+
+unapply
+