summaryrefslogtreecommitdiffstats
path: root/desktop/Executable_sbase.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /desktop/Executable_sbase.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/Executable_sbase.mk')
-rw-r--r--desktop/Executable_sbase.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/desktop/Executable_sbase.mk b/desktop/Executable_sbase.mk
new file mode 100644
index 0000000000..9c36165b8b
--- /dev/null
+++ b/desktop/Executable_sbase.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,sbase))
+
+$(eval $(call gb_Executable_set_targettype_gui,sbase,YES))
+
+$(eval $(call gb_Executable_add_ldflags,sbase,\
+ /ENTRY:wWinMainCRTStartup \
+))
+
+$(eval $(call gb_Executable_use_static_libraries,sbase,\
+ winlauncher \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,sbase,\
+ desktop/win32/source/applauncher/sbase \
+))
+
+$(eval $(call gb_Executable_add_nativeres,sbase,sbase/launcher))
+
+$(eval $(call gb_Executable_add_default_nativeres,sbase,$(PRODUCTNAME) Base))
+
+# vim: set ts=4 sw=4 et: