summaryrefslogtreecommitdiffstats
path: root/desktop/Executable_soffice_bin.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /desktop/Executable_soffice_bin.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/Executable_soffice_bin.mk')
-rw-r--r--desktop/Executable_soffice_bin.mk61
1 files changed, 61 insertions, 0 deletions
diff --git a/desktop/Executable_soffice_bin.mk b/desktop/Executable_soffice_bin.mk
new file mode 100644
index 0000000000..c2d811c2e8
--- /dev/null
+++ b/desktop/Executable_soffice_bin.mk
@@ -0,0 +1,61 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,soffice_bin))
+
+$(eval $(call gb_Executable_set_include,soffice_bin,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/desktop/source/inc \
+))
+
+$(eval $(call gb_Executable_add_defs,soffice_bin,\
+ $(if $(DISABLE_DYNLOADING),$(if $(SYSTEM_LIBXML),,-DNOTEST_xmlCleanupParser)) \
+))
+
+$(eval $(call gb_Executable_use_libraries,soffice_bin,\
+ sal \
+ sofficeapp \
+))
+
+$(eval $(call gb_Executable_add_cobjects,soffice_bin,\
+ desktop/source/app/main \
+))
+
+$(eval $(call gb_Executable_add_prejs,soffice_bin,$(SRCDIR)/static/emscripten/soffice_args.js))
+
+ifeq ($(OS),WNT)
+
+$(eval $(call gb_Executable_set_targettype_gui,soffice_bin,NO))
+
+$(eval $(call gb_Executable_add_nativeres,soffice_bin,sofficebin/officeloader))
+
+$(eval $(call gb_Executable_add_default_nativeres,soffice_bin,$(PRODUCTNAME)))
+
+ifeq ($(COM),MSC)
+
+$(eval $(call gb_Executable_add_ldflags,soffice_bin,\
+ /STACK:10000000 \
+))
+
+endif
+
+endif
+
+ifeq ($(OS),EMSCRIPTEN)
+$(call gb_LinkTarget_get_target,$(call gb_Executable_get_linktarget,soffice_bin)) : $(call gb_StaticLibrary_get_linktarget_target,unoembind)
+$(call gb_LinkTarget_get_headers_target,$(call gb_Executable_get_linktarget,soffice_bin)) : $(call gb_StaticLibrary_get_headers_target,unoembind)
+$(call gb_LinkTarget__static_lib_dummy_depend,unoembind)
+
+$(eval $(call gb_Executable_add_ldflags,soffice_bin,\
+ -s EXPORTED_FUNCTIONS=["_main"$(COMMA)"_libreofficekit_hook"$(COMMA)"_libreofficekit_hook_2"$(COMMA)"_lok_preinit"$(COMMA)"_lok_preinit_2"] -Wl$(COMMA)--whole-archive $(call gb_StaticLibrary_get_target,unoembind) -Wl$(COMMA)--no-whole-archive \
+))
+
+endif
+
+# vim: set ts=4 sw=4 et: