summaryrefslogtreecommitdiffstats
path: root/desktop/Extension_test-passive.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /desktop/Extension_test-passive.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/Extension_test-passive.mk')
-rw-r--r--desktop/Extension_test-passive.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/desktop/Extension_test-passive.mk b/desktop/Extension_test-passive.mk
new file mode 100644
index 0000000000..ef42f3b1b8
--- /dev/null
+++ b/desktop/Extension_test-passive.mk
@@ -0,0 +1,35 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Extension_Extension,test-passive,desktop/test/deployment/passive,nodeliver))
+
+$(eval $(call gb_Extension_add_file,test-passive,generic.components,$(call gb_Rdb_get_target,passive_generic)))
+
+$(eval $(call gb_Extension_add_file,test-passive,platform.components,$(call gb_Rdb_get_target,passive_platform)))
+
+$(eval $(call gb_Extension_add_files,test-passive,, \
+ $(SRCDIR)/desktop/test/deployment/passive/Addons.xcu \
+ $(SRCDIR)/desktop/test/deployment/passive/ProtocolHandler.xcu \
+ $(SRCDIR)/desktop/test/deployment/passive/passive_python.py \
+ $(call gb_Jar_get_target,passive_java) \
+))
+
+$(eval $(call gb_Extension_add_files,test-passive,help/en, \
+ $(SRCDIR)/desktop/test/deployment/passive/help/en/help.tree \
+))
+
+$(eval $(call gb_Extension_add_files,test-passive,help/en/org.openoffice%2Fframework%2Fdesktop%2Ftest%2Fdeployment%2Fpassive, \
+ $(SRCDIR)/desktop/test/deployment/passive/help/en/main.xhp \
+))
+
+$(eval $(call gb_Extension_add_libraries,test-passive, \
+ passive_native \
+))
+
+# vim: set noet sw=4 ts=4: