summaryrefslogtreecommitdiffstats
path: root/desktop/Library_offacc.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /desktop/Library_offacc.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/Library_offacc.mk')
-rw-r--r--desktop/Library_offacc.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/desktop/Library_offacc.mk b/desktop/Library_offacc.mk
new file mode 100644
index 0000000000..fb1a162b2b
--- /dev/null
+++ b/desktop/Library_offacc.mk
@@ -0,0 +1,32 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,offacc))
+
+$(eval $(call gb_Library_use_sdk_api,offacc))
+
+$(eval $(call gb_Library_use_custom_headers,offacc,\
+ officecfg/registry \
+))
+
+$(eval $(call gb_Library_use_libraries,offacc,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+))
+
+$(eval $(call gb_Library_set_componentfile,offacc,desktop/source/offacc/offacc,services))
+
+$(eval $(call gb_Library_add_exception_objects,offacc,\
+ desktop/source/offacc/acceptor \
+))
+
+# vim: set ts=4 sw=4 et: