summaryrefslogtreecommitdiffstats
path: root/desktop/UIConfig_deployment.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /desktop/UIConfig_deployment.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/UIConfig_deployment.mk')
-rw-r--r--desktop/UIConfig_deployment.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/desktop/UIConfig_deployment.mk b/desktop/UIConfig_deployment.mk
new file mode 100644
index 0000000000..80e5e96c12
--- /dev/null
+++ b/desktop/UIConfig_deployment.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UIConfig_UIConfig,desktop))
+
+$(eval $(call gb_UIConfig_add_uifiles,desktop,\
+ desktop/uiconfig/ui/dependenciesdialog \
+ desktop/uiconfig/ui/extensionmanager \
+ desktop/uiconfig/ui/extensionmenu \
+ desktop/uiconfig/ui/installforalldialog \
+ desktop/uiconfig/ui/licensedialog \
+ desktop/uiconfig/ui/showlicensedialog \
+ desktop/uiconfig/ui/updatedialog \
+ desktop/uiconfig/ui/updateinstalldialog \
+ desktop/uiconfig/ui/updaterequireddialog \
+))
+
+# vim: set noet sw=4 ts=4: