summaryrefslogtreecommitdiffstats
path: root/desktop/WinResTarget_scalc.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /desktop/WinResTarget_scalc.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'desktop/WinResTarget_scalc.mk')
-rw-r--r--desktop/WinResTarget_scalc.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/desktop/WinResTarget_scalc.mk b/desktop/WinResTarget_scalc.mk
new file mode 100644
index 0000000000..7060dcb775
--- /dev/null
+++ b/desktop/WinResTarget_scalc.mk
@@ -0,0 +1,27 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_WinResTarget_WinResTarget,scalc/launcher))
+
+$(eval $(call gb_WinResTarget_set_include,scalc/launcher,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/sysui/desktop \
+))
+
+$(eval $(call gb_WinResTarget_add_defs,scalc/launcher,\
+ -DRES_APP_ICON=icons/calc_app.ico \
+))
+
+$(eval $(call gb_WinResTarget_add_dependencies,scalc/launcher,\
+ sysui/desktop/icons/calc_app.ico \
+))
+
+$(eval $(call gb_WinResTarget_set_rcfile,scalc/launcher,desktop/win32/source/applauncher/launcher))
+
+# vim: set ts=4 sw=4 et: